none
Sql Azure Data Sync 2.1 Frame Work (adding more tables to the existing setup) RRS feed

  • Question

  • Hi,

    I have setup data sync between sqlazure(Remote) and the local server. Initially i have set up the data sync for only few tables. It worked great.

     I am using data sync 2.1 frame work. After few days i added another 20 tables to the list recompiled my code and tried setup it didn't work. When i run the application it says the scope exists already. The scope exists already is an old one and the recently added tables are not in that scope. So when i try sync i dont see the new tables. How can i overcome this? As of i dropped the azure db and recreated so it fixed in setting up, but the sync is not working because the old scope has only the old set of tables. Is there a way to update the scope so that i can add more tables going forward> I would appreciate if someone can help me on this. 

     It get an error the  "Microsoft.Synchronization.Data.DbSyncException: Cannot apply changes because the  local provider does not have adapters configured for the following tables that were received from the remote provider" I would appreciate if someone can help me on this.

     Thanks,

    Jay

    Monday, October 11, 2010 7:33 PM

All replies

  • Hi,

    you need to drop the scope, recreate it and perform the sync again.

    • Proposed as answer by Rahul-P Sunday, January 23, 2011 9:30 AM
    Tuesday, January 18, 2011 9:23 AM