locked
CRM 2013 not displaying Metadata only WSDL definition RRS feed

  • Question

  • it seems that this is not new or extremelly simple to fix, however i found this issue not a show stoper, I 'm using external tools and some custom powershell cmdlets that connects to the Organization service with no issues, but when i use the UI (web site) on prem, using the Developer Resources only got the WSDL defintion.

    Also checked for errors and no errors are displayed in the Event viewer or the CRM trace files

    any ideas on how to get the Metadata?

    <?xml version="1.0" encoding="utf-8"?> <wsdl:definitions name="OrganizationService" targetNamespace="http://schemas.microsoft.com/xrm/2011/Contracts" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:wsx="http://schemas.xmlsoap.org/ws/2004/09/mex" xmlns:wsa10="http://www.w3.org/2005/08/addressing" xmlns:tns="http://schemas.microsoft.com/xrm/2011/Contracts" xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy" xmlns:wsap="http://schemas.xmlsoap.org/ws/2004/08/addressing/policy" xmlns:msc="http://schemas.microsoft.com/ws/2005/12/wsdl/contract" xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:wsam="http://www.w3.org/2007/05/addressing/metadata" xmlns:wsaw="http://www.w3.org/2006/05/addressing/wsdl" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:i0="http://schemas.microsoft.com/xrm/2011/Contracts/Services" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"> <wsdl:import namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Services" location="http://local/POC/XRMServices/2011/Organization.svc?wsdl=wsdl0"/> <wsdl:types/> <wsdl:service name="OrganizationService"> <wsdl:port name="CustomBinding_IOrganizationService" binding="i0:CustomBinding_IOrganizationService"> <soap12:address location="http://local/POC/XRMServices/2011/Organization.svc"/> <wsa10:EndpointReference> <wsa10:Address>http://local/POC/XRMServices/2011/Organization.svc</wsa10:Address> <Identity xmlns="http://schemas.xmlsoap.org/ws/2006/02/addressingidentity"> <Upn>CRMSVCDEV@DOMAIN.LOCAL</Upn> </Identity> </wsa10:EndpointReference> </wsdl:port> </wsdl:service> </wsdl:definitions>

    abe.

    Thursday, May 29, 2014 8:26 PM

All replies

  • it seems that this is not new or extremelly simple to fix, however i found this issue not a show stoper, I 'm using external tools and some custom powershell cmdlets that connects to the Organization service with no issues, but when i use the UI (web site) on prem, using the Developer Resources only got the WSDL defintion.

    Also checked for errors and no errors are displayed in the Event viewer or the CRM trace files

    any ideas on how to get the Metadata? 

    <?xml version="1.0" encoding="utf-8"?> <wsdl:definitions name="OrganizationService" targetNamespace="http://schemas.microsoft.com/xrm/2011/Contracts" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:wsx="http://schemas.xmlsoap.org/ws/2004/09/mex" xmlns:wsa10="http://www.w3.org/2005/08/addressing" xmlns:tns="http://schemas.microsoft.com/xrm/2011/Contracts" xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy" xmlns:wsap="http://schemas.xmlsoap.org/ws/2004/08/addressing/policy" xmlns:msc="http://schemas.microsoft.com/ws/2005/12/wsdl/contract" xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:wsam="http://www.w3.org/2007/05/addressing/metadata" xmlns:wsaw="http://www.w3.org/2006/05/addressing/wsdl" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:i0="http://schemas.microsoft.com/xrm/2011/Contracts/Services" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"> <wsdl:import namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Services" location="http://local/POC/XRMServices/2011/Organization.svc?wsdl=wsdl0"/> <wsdl:types/> <wsdl:service name="OrganizationService"> <wsdl:port name="CustomBinding_IOrganizationService" binding="i0:CustomBinding_IOrganizationService"> <soap12:address location="http://local/POC/XRMServices/2011/Organization.svc"/> <wsa10:EndpointReference> <wsa10:Address>http://local/POC/XRMServices/2011/Organization.svc</wsa10:Address> <Identity xmlns="http://schemas.xmlsoap.org/ws/2006/02/addressingidentity"> <Upn>CRMSVCDEV@DOMAIN.LOCAL</Upn> </Identity> </wsa10:EndpointReference> </wsdl:port> </wsdl:service> </wsdl:definitions>

    abe.

    Thursday, May 29, 2014 8:23 PM