locked
Problem with installation of web components server (failed to create web application) on Server 2008 RRS feed

  • Question

  • I have a problem when installing OCS 2007 R2 standard edition. When installing the Web components server I receive the following error message:

    Failed to create web application (-2147024809 /Root/RequestHandlerExt ).

    I think this problem is related to the installation on Windows Server 2008 and IIS 7.

    Part of my error log:
    Action 13:59:58: StartMetabaseTransaction. Starting IIS Metabase Transaction
    MSI (s) (00:00) [13:59:58:387]: Executing op: CustomActionSchedule(Action=StartMetabaseTransaction,ActionType=11265,Source=BinaryData,Target=**********,CustomActionData=**********)
    MSI (s) (00:E4) [13:59:58:387]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI702F.tmp, Entrypoint: StartMetabaseTransaction
    MSI (s) (00:C8) [13:59:58:387]: Generating random cookie.
    MSI (s) (00:C8) [13:59:58:387]: Created Custom Action Server with PID 4920 (0x1338).
    MSI (s) (00:B0) [13:59:58:418]: Running as a service.
    MSI (s) (00:B0) [13:59:58:418]: Hello, I'm your 32bit Elevated custom action server.
    MSI (s) (00:00) [13:59:58:434]: Executing op: ActionStart(Name=RollbackMetabaseTransaction,Description=Rolling back IIS Metabase Transaction,)
    Action 13:59:58: RollbackMetabaseTransaction. Rolling back IIS Metabase Transaction
    MSI (s) (00:00) [13:59:58:434]: Executing op: CustomActionSchedule(Action=RollbackMetabaseTransaction,ActionType=11521,Source=BinaryData,Target=**********,CustomActionData=**********)
    MSI (s) (00:00) [13:59:58:434]: Executing op: ActionStart(Name=CommitMetabaseTransaction,Description=Committing IIS Metabase Transaction,)
    Action 13:59:58: CommitMetabaseTransaction. Committing IIS Metabase Transaction
    MSI (s) (00:00) [13:59:58:434]: Executing op: CustomActionSchedule(Action=CommitMetabaseTransaction,ActionType=11777,Source=BinaryData,Target=**********,CustomActionData=**********)
    MSI (s) (00:00) [13:59:58:434]: Executing op: ActionStart(Name=WriteMetabaseChanges,Description=Installing Metabase Keys and Values,)
    Action 13:59:58: WriteMetabaseChanges. Installing Metabase Keys and Values
    MSI (s) (00:00) [13:59:58:434]: Executing op: CustomActionSchedule(Action=WriteMetabaseChanges,ActionType=11265,Source=BinaryData,Target=**********,CustomActionData=**********)
    MSI (s) (00:30) [13:59:58:434]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI705F.tmp, Entrypoint: WriteMetabaseChanges
    WriteMetabaseChanges:  Error 0x80070057: failed to create web application: /Root/RequestHandlerExt
    Error 26105. Failed to create web application.  (-2147024809   /Root/RequestHandlerExt      )
    MSI (s) (00!9C) [14:01:42:564]: Product: Microsoft Office Communications Server 2007 R2, Web Components Server -- Error 26105. Failed to create web application.  (-2147024809   /Root/RequestHandlerExt      )

    WriteMetabaseChanges:  Error 0x80070057: failed to create ASP App


    Dynares Groep B.V.
    Saturday, April 4, 2009 12:06 PM

All replies


  • Did you select the IIS 6 Compatibility Pack during installatoin of the Windows Server 2008 IIS 7 server role? Check out this post that may give you some addtional pointers to this issue.

    Do let us know if this helps. Thanks.


    TechNet Forum Moderator - http://www.leedesmond.com/weblog/
    Saturday, April 4, 2009 9:35 PM
    Moderator
  • I have the same ptoblem.

    The above reponse was not helpful.  I have installed all the components as instructed in that link before I even visited that link.  Needless to say there is very little information about installing on Server 2008 and the IIS issues.  Very annoying.

    I had to figure out to create a website on my own.  Older versions of IIS automatically installed a default website now apparently 2008 with IIS 7 does not.  So fine I installed one and the process got further to this point, Failed to create web application.

    I will continue to struggle while waiting for some suggestions.

    I don't know why the error messages and such are so cryptic?  Why doesn't it just say what is wrong and what is expected or prerequisite.

    -Barry
    Monday, May 4, 2009 2:36 AM
  • The way I solved my problem was to delete the web site, delete the application pool, then create a new application pool, followed by creating a new website named "Default Website".

    I think that would have worked the first time if I had just done that in that order, but I did it after much munging around things which apparently got something cross-ways.

    -Barry

    • Proposed as answer by Barry Adkins Friday, May 15, 2009 7:58 PM
    Friday, May 15, 2009 7:58 PM
  • +1 for Barry Adkins' answer.  I had this same issue and tried EVERYTHING, before simply deleting the web site and making a new one.  I didn't have to use the web site identifier with adsutil, because it already had the identifier '1'. 

    However, the name MUST BE "Default Web Site", otherwise you will encounter another issue down the track.  The error will be 'Cannot find SITE object with identifier "Default Web Site/Etc/Place/Null"'.

    Saturday, September 5, 2009 3:36 PM
  • Make sure which all pre-requisites like .net are installed. To save time, remove your IIS and install again.

    Servermanagercmd -i web-server
    Servermanagercmd -i web-webserver
    Servermanagercmd -i web-common-http
    Servermanagercmd -i web-static-content
    Servermanagercmd -i web-dir-browsing
    Servermanagercmd -i web-http-errors
    Servermanagercmd -i web-http-redirect
    Servermanagercmd -i web-health
    Servermanagercmd -i web-http-logging
    Servermanagercmd -i web-request-monitor
    Servermanagercmd -i web-security
    Servermanagercmd -i web-basic-auth
    Servermanagercmd -i web-windows-auth
    Servermanagercmd -i web-digest-auth
    Servermanagercmd -i web-filtering
    Servermanagercmd -i web-performance
    Servermanagercmd -i web-stat-compression
    Servermanagercmd -i web-mgmt-tools
    Servermanagercmd -i web-mgmt-console
    Servermanagercmd -i web-mgmt-compat
    Servermanagercmd -i web-metabase
    Servermanagercmd -i web-wmi
    Servermanagercmd -i web-lgcy-scripting
    Servermanagercmd -i web-lgcy-mgmt-console
    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist | http://brunoestrozi.spaces.live.com
    Saturday, September 5, 2009 6:25 PM