locked
CRM 2013 Custom Workflow Debugging Error RRS feed

  • Question

  • Hi Everyone,

    I am trying to debug a custom workflow and I get this error in Plugin Registration Tool before it hits the breakpoint in Visual Studio.

    Error:

    Could not load file or assembly 'Microsoft.Xrm.Sdk.Workflow, Version=6.0.0.0, Culture=neutral


    Please help me!

    Regards,

    Wesley


    • Edited by Paul Wesley Thursday, November 27, 2014 5:20 PM
    Thursday, November 27, 2014 1:17 PM

All replies

  • Check the version of the library you have referred in your project. Error message says it's looking for Microsoft.Xrm.Sdk.Workflow, Version=6.0.0.0 and couldn't find.

    Sachith Chandrasiri

    Friday, November 28, 2014 2:16 AM
  • Hi Paul,

    Make sure you have the latest SDK with the latest registration tool. As Sachith mentioned, check your project whether it is referring to the correct Assembly(dll).

    As you are getting this error in Plugin Registration Tool you can try putting the dll in folder in SDK from where you run the plugin registration tool. (CRM SDK\tools\pluginregistration\bin\Debug). It should ideally have been a part of the SDK.

    Thanks,

    Prasad

    Friday, November 28, 2014 3:32 AM
  • Hello Prasad,

    I have downloaded latest SDK and added the dll in CRM SDK\tools\pluginregistration\bin\Debug.
    I still get the same error.

    Any more help please?

    Regards,

    Wesley

    Monday, December 1, 2014 4:28 PM
  • Hello Sachith,

    I have downloaded latest SDK and added the same dll 'Microsoft.Xrm.Sdk.Workflow' in the Visual Studio. 
    And I still get the same error while debugging.

    Any more help please?

    Regards,

    Wesley

    Monday, December 1, 2014 4:30 PM