locked
cmicnfg.cpl

    Question

  • Windows XP Home Edition - when booting up, message appears - "Error loading cmicnfg.cpl". Re-installed Windows; message still appears. How to make it go away?


    Saturday, October 18, 2008 12:25 PM

All replies

  • Background: This error occurs after trying to uninstall the updated (and overrated) C-Media WDM Audio Driver for onboard sound that appears after upgrading to XP SP2 and/or going to WindowsUpdate. Likely the driver didn't work, so you tried uninstalling the driver and were going to put back the old Realtek AC'97 driver, but couldn't get rid of the updated driver.

    To fix: Start, Run, type in "regedit" (no quotes), and delete the cmaudio string from
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run. This makes it so it will not run on startup and try to find the cpl file that was deleted during the uninstall or not installed correctly by the installer in the first place, whichever your case depending on when you started seeing the error. If your sound was working perfectly before this, you are done. To get your sound working again if it isn't, read on -

    While still in the registry editor, click on the top computer icon in the Registry Editor to highlight it (so that it will do a complete search of the registry and not just from your present point forward), do a Find (Ctrl+F) and find and delete all KEYS related to cmaudio and C-Media, not just the string entries, but the KEYS, except for that entry in the Run key I mentioned above, just delete the cmaudio string for that one.

    Delete the string "CMCPlus" from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Control Panel\Cpls to get rid of the Control Panel icon, and delete the file it points to that resides in C:\Windows\System32.

    Download this remove utility from

    http://ekiis.com/Freesoft/binary/remove11.zip

    and run the file you find in the zip file - it can be ran without extracting it from the zip. Take out the C-Media Audio Driver line.

    -- NOTE: This utility is for taking the name out of the Add/Remove Programs section only, and does not remove it from your computer, but it is very useful for issues like this when we are MANUALLY uninstalling a program to take it out of the Programs list and should work in 98/ME/2000/XP.

    Delete these files from the C:\Windows\System32 directory (or "System" directory for Win98)

    cmirmdrv.exe
    cmirmdrv.dll
    cmuda.dll

    Delete everything you can readily delete in C:\Temp, C:\WINDOWS\prefetch (XP only), C:\WINDOWS\Temp, and C:\Documents and Settings\%YourName%\Local Settings\Temp (2000 and XP only), so that there will not be any files left for it to try to recover the driver from. You will likely have to leave things that start with hsperfdata_ and Perflib_Perfdata_***.dat files if you find them, but should be able to delete most others without changing attributes.

    Now open the Device Manager (Right-click "My Computer", hit "Manage", then find Device Manager in the Computer Management console). Right-click the C-Media WDM driver under Sound, video, and game controllers, hit Uninstall. Then right-click the top computer icon listed there with your hostname beside it, hit "Scan for hardware changes". It should install a generic "Multimedia Audio Controller" instead of the "C-Media WDM Audio Driver", though you might see that C-Media Audio for just an instant before it reverts back to a generic driver (if it stays, you'll have to go back through the registry again, delete the system files again, and do a full search of your hard drive for those files so they don't get re-copied again). From here you can download your specific Realtek AC'97 Audio Driver setup.exe file here or use your motherboard's installation CD to re-install and you should have sound again.

    Sunday, October 19, 2008 6:07 AM
  • Thanks  mmak_leo, this was very helpful. I was feverishly browsing the Internet to find a way to uninstall the C-Media which resisted to go away despite a successful uninstall indication. Following your instructions I was able to uninstall it for good.

     

    Vahe

    Sunday, November 16, 2008 10:30 PM
  • Thank you so much. I was able to remove CMedia from my registry and the sound did not go away.

    Friday, November 21, 2008 10:22 AM
  • I've got the same message but I don't have CMAudio under  Current version- Run. Also the remove utility  htttp://ekiis.com/Freesoft/binary/remove11.zip is no longer there (good job i looked for it before I tried the uninstall). has anyone got any advice on how I fix the thing

     

    Thursday, January 08, 2009 1:45 AM