What Services Does the Client Connector Install? Trying to Solve Connector Install Problem. RRS feed

  • Question

  • I'm trying to troubleshoot a problem installing the connector on a PC. Investigations so far lead me to believe the connector is failing trying to install one of its services. So trying to resolve this, I'm trying to confirm that all services installed by a previous install have been removed and that I have the necessary access to all the directories. But I can't find a comprehensive list of services anywhere.

    Among other things, so far I have tried what appear to be the most common causes reported here which include...
    ...verifying the server can be pinged and directories opened from the client as well as remote desktop sessions.
    ...verifying task scheduler is working by creating a test task and running it.
    ...trying to remove all tasks on the client related to the windows server.
    ...creating the missing "Windows Server" directory in Windows\System32\Tasks\Microsoft\Windows.
    ...cleaning the registry of all references to "windows server," "windowsserver," "launchpad," and "dashboard" except for those related to Terminal Server.

    But I continue run into the same problem. The connect install starts and seems to run correctly past the problems for the server password, wake up option, and feedback program. It then looks like it's installing. But when it gets to around 50-60% done, the status bar shoots from there to almost 100% and then immediately rolls back and returns the message "The Installation is Cancelled" and "The Windows Home Server 2011 Connector has encountered an unexpected error. Click Close to undo most of the changes that were made to this computer."

    The result is the client is added to the list of computers shown on the server dashboard but the connector is not installed on the client. In the ClientCore.msi.log, the reported error appears to be "Cannot create a file when that file already exists. (Exception from HRESULT: 0x800700B7)" leading me to believe the problem is creating a task that already exists from the previous installation.

    Alternately, I suspect it may be a problem creating files in the WinSxS directory. But again, I have no idea what files, of the over 65,000 files in that directory, to check to see if they already exist. So I am trying to eliminate Scheduled Tasks as the cause but don't know exactly what files to check for or their directories to make sure it has the necessary rights.
    I have setup a clone of my OS disk so can test freely if anyone has any information that might help.

    MSI (s) (BC:E8) [13:48:02:590]: Executing op: CustomActionSchedule(Action=AddScheduledTasks,ActionType=3073,Source=BinaryData,Target=CAQuietExec,CustomActionData="C:\Program Files\Windows Server\Bin\runtask.exe" /asm:"%ProgramFiles%\Windows Server\Bin\ClientSetupCommon.dll" /class:Microsoft.WindowsServerSolutions.ClientSetup.ScheduledTasks.ClientTasks /method:AddScheduledTasks /task:AddScheduledTasks /suppressException:true)
    MSI (s) (BC:40) [13:48:02:606]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSIDAD8.tmp, Entrypoint: CAQuietExec
    CAQuietExec:  System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.InteropServices.COMException: Cannot create a file when that file already exists. (Exception from HRESULT: 0x800700B7)
    CAQuietExec:     at TaskSchedulerV2.ITaskFolder.RegisterTaskDefinition(String Path, ITaskDefinition pDefinition, Int32 flags, Object UserId, Object password, _TASK_LOGON_TYPE LogonType, Object sddl)
    CAQuietExec:     at Microsoft.WindowsServerSolutions.Common.ProviderFramework.SchedulerVersion2.RegisterTask(TaskDefinition definition)
    CAQuietExec:     at Microsoft.WindowsServerSolutions.ClientSetup.ScheduledTasks.ClientTasks.AddScheduledTasks()
    CAQuietExec:     --- End of inner exception stack trace ---
    CAQuietExec:     at System.RuntimeMethodHandle.InvokeMethod(Object target, Object arguments, Signature sig, Boolean constructor)
    CAQuietExec:     at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object parameters, Object arguments)
    CAQuietExec:     at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture)
    CAQuietExec:     at Microsoft.WindowsServerSolutions.Common.ProviderFramework.Program._invokeMethod(Type classType, MethodInfo mi)
    CAQuietExec:     at Microsoft.WindowsServerSolutions.Common.ProviderFramework.Program.Main(String args)
    CAQuietExec:  Error 0x80131604: Command line returned an error.
    CAQuietExec:  Error 0x80131604: CAQuietExec Failed
    CustomAction AddScheduledTasks returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    01/23/2017 13:48:02.873 [11708]: Assembly Install: Failing with hr=80070005 at RemoveDirectoryAndChildren, line 393
    01/23/2017 13:48:02.873 [11708]: Detailed info about C:\WINDOWS\assembly\tmp\Y72ROIG4\WssgCommon.dll
    01/23/2017 13:48:02.873 [11708]:     File attributes: 00000080

    And in case it matters, the PC in question is running Win 10 Pro. It did have the connector installed previously for another WHS. But that had stopped working which a big part of the reason I set up a new server thinking the problem might have been on the server re-adding a PC that already was connected.

    Separately, I have another PC running almost identical hardware (mainboard, memory, disk configuration) which connected with no problems.

    Tuesday, January 24, 2017 5:58 PM

All replies

  • Hi,

    According to your description, my understanding is that specific Windows 10 failed to connect to Windows Home Server 2011.

    As you mentioned that you had tried to manually clear stale Connector installation files, please consider the following and just for confirmation:
    1. Uninstall Windows Home Server 2011 Connector from Control Panel – Programs and Features.
    2. Delete “Windows Server” folder on Task Schedule – Microsoft – Windows.
    3. Delete “Windows Server” folder on “%ProgramData%\Microsoft”.
    4. Delete the client on WHS 2011 Dashboard – Computers and Backup.
    5. Reboot the client system in Clean Boot and re-connect to WHS 2011.

    If the problem persists, try to create a new local account with admin permission on the client, log on with this new account and try to connect to WHS 2011 to check the result. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 26, 2017 5:17 AM
  • Hi Eve,

    Thanks for the suggestions. Unfortunately I had the exact same results after trying the steps you suggested. I also had the same problems using a new Administrator account I created for testing.

    I wish I could understand what that line in the log file means. It keeps telling me an exception has been thrown because it cannot create a file when that file already exists.

    If I could figure out what file that is from the log file I could try to delete it manually. But I can't seem to figure out what file it's referring to.

    Any other ideas or suggestion how I could figure out what the file the log is talking about?


    Thursday, January 26, 2017 10:51 PM
  • Hi,

    I am afraid that it difficult to identify the exiting file exactly according to relate log files.

    I would recommend you to check the Event Viewer on the client, make sure if there is any relate event has been logged.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 7, 2017 4:50 AM
  • Hello,

    I had a similar problem trying to re-install the connector software (WHS 2011).  Followed the steps below from Microsoft site and I was able to complete my install.  

    1. Click “Start” -> Under “Start Search” -> Type “Regedit” and press Enter


    2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache


    3. Right click on TaskCache and select export


    4. Save to a file on the desktop.


    After that, please delete the WindowsServer folder in the TaskCache\Tree\Microsoft\Windows.


    Reboot and try the intall again.  Good luck.  Let me know if this works for you.

    Tuesday, February 28, 2017 4:44 AM