locked
Web Conference component installed but not really? RRS feed

  • Question

  • Hi all.

     

    I've installed an Enterprise Edition server on one physical machine with no errors.

     

    When I validate the web conference component it can't connect to https://<FQDN>:444/LiveServer/DataMCU/ and when I look in the IIS Manager there's no directory called LiveServer at all for the web server, virtual or physical.

     

    There are no files on the physical disk for the LiveServer components.

     

    Checking Add/remove Programs reveals that the Web Conferencing component is installed.

     

    I've also enabled web conferencing in the global properties for our forest without any errors.

     

    We are using self-signed certificates but these are importet into the trusted root certificate folder of all servers and clients.

     

    Worth mentioning is that the IM functionality works as long as I don't try to start a conference. Live Meeting isn't working either when I test the connection in the LM configuration.

     

    I've try to read up on how to troubleshoot further but there isn't a whole lot of information available.

     

    Any ideas?

     

    TIA.

    Monday, September 8, 2008 2:42 PM

All replies

  • It sounds like the installation may have failed during that portion.  I haven't tried this but you could uninstall just the Web Conferencing role from the server and try reinstalling it; although I'm not sure if OCS will even let you do that on a consolidated Enterprise Front-End installation, if there are currently no other server's holding that role. 
    Monday, September 8, 2008 11:29 PM
    Moderator
  • Hi Jeff.

     

    Thanks for your quick reply, unfortunately a reinstall didn't solve the problem.

     

    It seems to me as if there's some old "junk" left behind from a previous, botched installation of OCS and when starting the Web Conference service I see the following in the event log:

     

    Trusted server has been created

    FQDN: gons7014.domain.com

     

    gons7014 is the old OCS server and not the one I'm currently using.

     

    The above message is followed by this one:

     

    Office Communications Server Web Conferencing Server could not be started

    Message: No corresponding MSFT_SIPMCUSetting for service DN 'CN=LS DATA MCU,CN=Microsoft,CN=OCSDEMO1,CN=Computers,DC=domain,DC=com'.

    at Microsoft.Rtc.Internal.Wmi.WmiConsumer.get_Msft_SipMcuSetting()

    at Microsoft.Rtc.Internal.Wmi.WmiConsumer.get_Msft_SipMcuFactorySetting()

    at Microsoft.Rtc.Internal.Wmi.WmiConsumer.get_PoolDn()

    at Microsoft.Rtc.Internal.Wmi.WmiConsumer.get_PoolInstance()

    at Microsoft.Rtc.Internal.Wmi.WmiConsumer.get_Backend()

    at Microsoft.Rtc.Internal.Wmi.WmiConsumer.GetInitialSettings(WmiConsumerClassEntry entry)

    at Microsoft.Rtc.Internal.Wmi.WmiConsumer.Start()

    at Microsoft.Rtc.Server.DataMCU.Configuration.ServerConfiguration.StartWmiConsumer()

    at Microsoft.Rtc.Server.DataMCU.Configuration.ServerConfiguration.Initialize()

    at Microsoft.Rtc.Server.DataMCU.ServiceWorker.StartServer(String[] args)

    Resolution:

    Look in previous event logs for more information about this error

     

    I've tried a quick and dirty fix and added gons7014 as an alias for ocsdemo1 (the correct server) but this won't fool OCS and the web conference service won't even start now.

     

    If I use the OCS admin tool gons7014 is only mentioned as an archiving server and not as a web conference server but archiving is disabled so I'm hoping that it won't be accessed.

     

    Is there a way to clean up the AD manually? [Edit: I found this blog post by you which I will go through and get back to you.]

     

    I also did a search for "LiveServer" on the ocsdemo1 server and the only thing I found was Microsoft.LiveServer.DLExpansion.dll in C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Group Expansion\Ext\Bin and C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Group Expansion\Int\Bin.

     

    Let me know if you need any more information.

     

    TIA.

    Tuesday, September 9, 2008 2:24 PM
  • In that case take a look at this blog article: http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=13

     

    You can poke around in the AD configuratino settings for OCS and see if you can locate and replace that old entry with the correct FQDN.

    Tuesday, September 9, 2008 2:52 PM
    Moderator
  • Yep, Google pointed me in that direction and I'll get back to you when I've had a chance to rummage through our AD a bit.

     

    Thanks.

    Wednesday, September 10, 2008 6:09 AM