A Bug About Tags

    General discussion

  • I  try to type Chinese words in the Tag TextBox, but the Input Method Editor doesn't work. I've tried many times, but only English words can be typed there.
    The IME works everywhere else.
    The solution is to type Chinese words somewhere else, then just make a copy and paste. There's no problem with displaying Chinese words.

    Another problem:If the CheckBox "Notify if there's no Tags" is switched on, even if I had copied & pasted Chinese words into the Tag TextBox, there would be a warning saying that no tag is found. However, the tags have already been added to the blog successfully.

    Live Writer Version:14.0.8064.206 zh-cn
    Monday, March 02, 2009 11:47 AM

All replies

  • Thanks for the feedback! We'll file a bug.
    Friday, March 06, 2009 11:19 PM
  • Actually, we can't reproduce this problem on a variety of platforms that we tried. Can you tell us the following:

    1) Windows version
    2) Windows language
    3) IME name

    Tuesday, March 10, 2009 1:43 AM
  • Windows Version: Windows XP Pro SP3 CHS (Microsoft Original Install Disk)
    Windows Language: Chinese Simplified
    IME name: Sougou PinYin V4.0

    I find something  new about this bug today.
    If I use Microsoft PinYin 2007, Chinese words can be typed into the Tag textBox. If I use Microsoft PinYin first, and then switch to SouGou IME, Chinese words can be typed. However, the "no tags" warning still shows up when trying to publish the diary.
    I record a video about the bug, you can reach it at Note: I will delete this video after 10 days.

    Tuesday, March 10, 2009 10:11 AM
  • Thanks for the info. The "no tags" warning will be corrected in a future release. That option actually refers to the "Insert Tags" feature on the sidebar (sorry, I don't know the Chinese translation) today--in the future it will also refer to the more useful native tagging feature that is now more widely used.
    Wednesday, March 11, 2009 7:02 AM