locked
all clients but one backup to WHS? RRS feed

  • Question

  • looked on many forums to solve this... I have WHS able to backup 2 client pc's no problem ( a vista laptop and a windows 7 laptop)

    however, my xp pro desktop will not commence the backup - event 12293 cannot ask privder (all zeros in ID) if volume is supported...

    tried all of the chkdsk solutions, vssadmin shadow service dll re-registering and volume signature adjusting with mbrwiz etc. --- same issue - all oft the client pc's including the

    laptops that did backup have acronis on them also - I know it is possible that acrons on the desktop could be an issue but would prefer to keep

    it installed.  (also tried adding value to registry to use microsoft vss provider - did not work...) - tried deleting keys under subscriptions and catalogs per other forum posts etc. - no luck ---

    1) since my other clients back up no problem it is not worth re-installing WHS, correct? 2) problem must be with the XP pro desktop somewhere -- the logs on the client error show event 12293, the event on the WHS is 270 - backup failed - reason 5??? - any help appreciated - thanx

    Saturday, September 25, 2010 11:42 PM

Answers

  • everyone...

    probelm is now corrected but unfortunately it took a complete re-install of xp pro on new hard drive.  No other solutions worked - not even the repair re-install.

    now to put everything back on the box..............

    I guess this should be marked as closed and sort-of answered...

     

     

     

    Thursday, October 14, 2010 4:19 PM

All replies

  • It's almost certainly vss problem on the client system. Can you please specify in more detail what steps you already tried (provide link to forum posts / instructions you actually used)?

    Also please check if you have any malware on this system (try using Malwarebytes). Then from a command prompt run the fcommands vssadmin list providers and vssadmin list writers.

    Wednesday, September 29, 2010 8:21 AM
    Moderator
  • thanks brubber - I recall your name from reading other related posts on troubleshooting this.

     

    I definitely agree the problem is on the client pc - I ran malwarebytes full scan - no issues

    I am not in front of that PC right now but will try to explain in detail what I have already tried

    - ran vsslist providers and writers - results seemed ok - present and stable but one could be missing and I wouldn't know

    - made sure shadow copy and microsoft volume shadow copy services are set to manual or auto and are running and can be started and

    stopped without issue - also check with net start (same thing i think)

    - tried chkdsk scans on all drives - client and svr

    - tried the re-registration of the dll's sugguested in other posts.

    - tried making sure keys listed in services and com match certain registry keys - don't have details in front of me on these but they did not work

    - tried uninstalling and reinstalling connector s/w

    - tried different users / names

    - tried renaming PC

    - tried renaming workgroup

    the "reason 5" seems to maybe be related to a security permission to access the remote volume from the server?

    - have NOT tried restoring the XP security and permission schemes back to default

    - tried disabling restore on the volumes on the XP box - no luck - then re-enabled - no luck

    - tried relaxing some of the security permissions, turining off the firewall etc. - no luck

    (my other clients, a vista laptop and a win 7 laptop backup of with the standard software firewalls left on) 

    currently thinking it may be due to acronis or my CA- antivirus (but I tried the backups with CA in snooze? - no luck)

    also tried to do some manual backups on the XP client PC with ntbackup - the logs do show a problem with the volume snapshot

    it tries to start in that mode for example to back up the system state or partition but then it fails and switches to another mode

    to complete the backups???

    more later-

    thanks

     

     

     

     

    Thursday, September 30, 2010 12:49 PM
  • still no luck solving this one!!!

    I reset all security, sharing and permissions on the xp pro box client back to to default - then reinstalled  W H S and connector - still backup errors

    same ones - can't create volume snapshot .. 12293 on client and log on whs - failed with reason 5 (permission problem between svr and client?)  -- client VSS errors - cannot ask provider if volume... etc. etc..

     

    also tried installing latest acronis to see if that would somehow fix the VSS issues - no help...

     

    after reinstall of WHS, the other clients (vista and 7) still back up as before.  only issues with XP clients continue.

    another thought is that the XP machine used to be in a domain... now same workgroup as WHS - could this be preventing the snap shot / shadow

    copy precesses?

    I removed the original acronis (including manual registry keys from other posts) no luck - prior to trying the latest one described above

    I have been through all forums I could find (gotserved, mark minasi's, this one, acronis, etc.) tried just about all solns -

    one more thought is something about a windows update "flag" in the registry about pending updates possibly preventing the snapshots???

    I have not checkd this out but my windows update before i disabled it recently always tries to install the same 4 .net updates????

    I ran some dagnostics on all of the .net packages and they all cleared ok 

     

    any ideas appreciated

    I really, really want to mark this one answered!!!! :)

    thanks

     

     

     

    Sunday, October 3, 2010 10:53 PM
  • Have you considered flattening the problem computer? Something is obviously wrong with it since updates are failing to install. Rather than spend an unknown but potentially large amount of time trying to fix it, rebuilding it from scratch might be a more practical approach.
    I'm not on the WHS team, I just post a lot. :)
    Monday, October 4, 2010 12:56 PM
    Moderator
  • thanks ken,

     

    I am going to give it a few more days...and then will do just that... I already have spent WAY too much time I just keep thinking I can fix it...

    I have a question regarding the next thing I was going to check... If I go on the WHS machine itself ( i know it is not supported to use the desktop!!) and examine the visible computers on my network - for the client pc's that have been set up with the connector software - I should see the remote drive shares from there, correct?  or will they not show up or be able to be mapped like a shared drive - I was going to see if the drives are visible on my others from the WHS vs. on the problem XP box?  --

    I did confirm that manual ntbackups of for example the system state from the xp pro box do not

    work in shadow copy mode - they try but fail and use another mode to complete - my xp box at work has no vss issues (aparently) and the logs show that those backups do use the shadow copy mode.  looks like if I get ntbackp to work the right way - the machine will probably remote backup to WHS like it is supposed to.  also I can do a manual acronis or ntbackup across the network to the user share on the WHS - this works (not in shadow copy mode for the ntbackup) .

    the other nagging event language is the 270 on the server - backup abort with reason 5

    coupled with the "cannot ask the provider if vol is supported" looks like a secrity permission issue?

     

    john 

    Tuesday, October 5, 2010 6:00 PM
  • Hi John,
    did you have at any time installed some other disk cloning tool (i.e. Symantec Ghost)? Those bring their own VSS providers, but do not always remove properly registry entries.

    If you have multiple disks, you can attempt the Configure Backup function for that computer in the console and check, if backup runs after excluding the first listed drive (or of the failed drive is not the first drive, that one).

    Best greetings from Germany
    Olaf

    Tuesday, October 5, 2010 9:29 PM
    Moderator
  • olaf,

    had acronis true image products, removed, used cleaner, and even installed new version

    no luck -- strange as i have other machines ( a vista laptop and a 7 laptop each with acronis)

    and these backup with WHS no problem...

    there are multiple disks on  the problem pc and I have tried selecting different ones in the

    console one at a time to see if one would work - none do?

    going to play around with mbrwiz /list  and mbrwiz /signature = to reset sig again on volumes

    and reboot twice etc. etc.  --

    I don't think Ghost was ever on the machine but maybe an old system works norton product a

    few years ago (w/o ghost i think)

     

    john 

    Tuesday, October 5, 2010 9:37 PM
  • Hi John,
    after uninstalling Acronis and rebooting, do you get any errors or warnings pointing to VSS provider (of Acronis or some other software)?

    Could you copy/paste these messages completely here?

    Best greetings from Germany
    Olaf

    Tuesday, October 5, 2010 9:54 PM
    Moderator
  • update - but no good news - hello germany?

    uninstalled acronis - rebooted...

    there does not appear to be a rogue provider still installed as vssadin list providers just lists the one i think it should?

    but there are the same errors in the attempted backup...

    here is the event 12293:

    Event Type: Error
    Event Source: VSS
    Event Category: None
    Event ID: 12293
    Date:  10/6/2010
    Time:  7:25:26 PM
    User:  N/A
    Computer: PRO1
    Description:
    Volume Shadow Copy Service error: Error calling a routine on the Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details Cannot ask provider {00000000-0000-0000-0000-000000000000} if volume is supported. [0x8000ffff] [hr = 0x8000ffff].

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 43 4f 52 43 4f 4f 52 43   CORCOORC
    0008: 39 30 34 00 00 00 00 00   904.....
    0010: 43 4f 52 43 4f 4f 52 43   CORCOORC
    0018: 38 32 30 00 00 00 00 00   820.....

    and..... here is the event 770 after the 4 or 5 12293 ones...

    Event Type: Error
    Event Source: HomeServer
    Event Category: HomeBackup
    Event ID: 770
    Date:  10/6/2010
    Time:  7:29:30 PM
    User:  N/A
    Computer: PRO1
    Description:
    Backup set 24 on SERVER failed: Microsoft.HomeServer.Backup.VSS.ShadowVolumeException: Exception from HRESULT: 0x8004230F ---> System.Runtime.InteropServices.COMException (0x8004230F): Exception from HRESULT: 0x8004230F
       at Microsoft.HomeServer.Backup.VSS.IVssBackupComponents.IsVolumeSupported(Guid ProviderId, String pwszVolumeName)
       at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet.CreateShadowVolume(VolumeInfo[] volumes)
       --- End of inner exception stack trace ---
       at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet.CreateShadowVolume(VolumeInfo[] volumes)
       at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet..ctor(VolumeInfo[] volumes)
       at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.RunWithoutCatch()
       at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.Run()

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    these are the ones....and, of course the one on the WHS, 270, abort with reason 5.

    I looked back on system logs and there was a 4321 thrown....

    The name "628 :1d" could not be registered on the Interface with IP address 192.168.0.9. The machine with the IP address 192.168.0.8 did not allow the name to be claimed by this machine.

    box in question USED to be in a domain - now a workgroup - i am thinking this is part of the issue - allthough I did try changing workgrup names etc. etc.

    john

    Thursday, October 7, 2010 12:36 AM
  • Are you sure vssadmin list providers and writers results are OK? So only Microsoft VSS (Shadow Copy) provider?

    If yes, did you originally install the system on this disk, or did you create / restore it using some imaging software?

    If you used imaging software:

    1. Uninstall Acronis and any other backup software you have installed on your system

    2. Make sure all references to this software are removed from the registry

    3. Disable system restore (Press Windows Key and Pause Break Key simultaneously, select system restore tab), then reboot.

    4. Enable system restore, now try creating a restore point manually. If this works try running backup.

    5. If this doesn't help please try changing the disk Volume ID as described overhere.

    If you didn't use imaging software please post output of vssadmin list providers (before and after steps 1 - 2 above), also please output from vssadmin list shadowstorage before and after step 3 and volume id's for all partitions on your system (in command prompt run dir c: to get volume id for c partition)

     

    Thursday, October 7, 2010 9:13 AM
    Moderator

  • brubber,

    providers and writers seem ok...

    o/s installed from xp pro disk, not imaged or restored...

    ran thru the steps anyway to see if any changes...

    the vssadmin list providers allways indicates just the one - beofore and after
    two acronis uninstall-install-and uninstalls...

    C:\>vssadmin list providers
    vssadmin 1.0 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001 Microsoft Corp.

    Provider name: 'MS Software Shadow Copy provider 1.0'
    Provider type: System
    Provider Id: {b5946137-7b9f-4925-af80-51abd60b20d5}
    Version: 1.0.0.7


    the writers...

    C:\>vssadmin list writers
    vssadmin 1.0 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001 Microsoft Corp.

    Writer name: 'MSDEWriter'
    Writer Id: {f8544ac1-0611-4fa5-b04b-f7ee00b03277}
    Writer Instance Id: {147fd3ca-18fe-4546-9d00-87f4070b5247}
    State: [1] Stable

    Writer name: 'Microsoft Writer (Service State)'
    Writer Id: {e38c2e3c-d4fb-4f4d-9550-fcafda8aae9a}
    Writer Instance Id: {31e70009-1417-476c-b49f-63328f80ed0d}
    State: [1] Stable

    Writer name: 'Microsoft Writer (Bootable State)'
    Writer Id: {f2436e37-09f5-41af-9b2a-4ca2435dbfd5}
    Writer Instance Id: {8a917b55-437a-42de-a457-148d5b579a82}
    State: [1] Stable

    Writer name: 'IIS Metabase Writer'
    Writer Id: {59b1f0cf-90ef-465f-9609-6ca8b2938366}
    Writer Instance Id: {0ca2a3c4-cde1-4bc4-8232-4e936ca997c1}
    State: [1] Stable

    Writer name: 'WMI Writer'
    Writer Id: {a6ad56c2-b509-4e6c-bb19-49d8f43532f0}
    Writer Instance Id: {3f5603db-63c0-4175-afd8-b21ad038aa5f}
    State: [1] Stable

    info on steps just taken

    1 & 2-- uninstalled acronis true image 2011 home, then used their removal tool as well
    on the registry, reboot.  - same vss outputs before and after - theirs was never listed-

    vssadmin listshadowstorage not valid? tried vssadmin list shadows
    returned "no shadow copies present on system" before step 3

    3- disbled system restore on all drives, rebooted, after reboot vssadmin list shadows
    indicated no shadow copies present in system...

    4- enabled system restore - all drives monitoring...

    5- tried manual ntbackup to see if it would use shadow copy mode...
     error trying to create volume shaodw copy!!!

    Backup Status
    Operation: Backup
    Active backup destination: File
    Media name: "backuptoshare.bkf created 10/7/2010 at 6:29 AM"


    Error returned while creating the volume shadow copy:8004230f
    Reverting to non-shadow copy backup mode.
    Backup of "System State"
    Backup set #2 on media #1
    Backup description: "Set created 10/7/2010 at 6:29 AM"
    Media name: "backuptoshare.bkf created 10/5/2010 at 8:03 PM"

    Backup Type: Copy

    Backup started on 10/7/2010 at 6:29 AM.
    Backup completed on 10/7/2010 at 6:30 AM.
    Directories: 173
    Files: 2967
    Bytes: 580,508,880
    Time:  1 minute and  23 seconds

     Volume in drive C is C:
     Volume Serial Number is 40EF-681C

     Directory of C:\


    E:\>dir e:
     Volume in drive E is cavgreen
     Volume Serial Number is 5CE8-594D

     Directory of E:\

    F:\>dir f:
     Volume in drive F is seagate
     Volume Serial Number is 3CCD-A610

     Directory of F:\

    G:\>dir g:
     Volume in drive G is recovery
     Volume Serial Number is 7824-581B

     Directory of G:\

    K:\>dir k:
     Volume in drive K is Elements
     Volume Serial Number is 2076-9B45

     Directory of K:\

    since the ntbackup failed with shadow copy mode I did not try whs backup again yet

    I will look at trying the volume signature change stuff again?

    - all vssadmin responses same as before right now?

    I may have deleted shadows a few days back - do they need to be re-set somehow?

    thanks,
    john

    Thursday, October 7, 2010 4:51 PM
  • may be normal for no shadow copies to be present on system

    my xp pro box at work that does not have vss issues reports same response...

     

    Thursday, October 7, 2010 4:53 PM
  • Please try step 5 from my previous post, or use mbrfix as described overhere

    If that also fails I suggest you try solution from Ken, flatten and reinstall.

    Friday, October 8, 2010 6:34 AM
    Moderator
  • Please check the clients registry and search for the names behind the key {b5946137-7b9f-4925-af80-51abd60b20d5} - and for any references associated with these.
    Is in HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\VSS\Providers\{b5946137-7b9f-4925-af80-51abd60b20d5} anything else than Microsoft Software Shadow Copy provider 1.0 listed?Best greetings from Germany
    Olaf

    Friday, October 8, 2010 7:28 PM
    Moderator
  • olaf, all references refer to only the ms provider 1.0 in current control set, ...set001, ...set002 (i have no 003) and ...set004

    one more reference to the string in an area called aplets or recent edits but no services or vss associated with it - probably from a week ago

    when i was trying to make sure the correct keys were pasted in the right location...

    going to try the offline volume and volume signature changes described in brubber's referenced link above - i already tried with mbrwiz on

    all local drives - no luck

     

    thanks again,

    john

    Friday, October 8, 2010 9:01 PM
  • Hm, having more than controlset001 and 002 points already to a more serious problem with your Windows installation, since those are the common sets.

    Btw. on my Windows 7 x64 machine the key looks as follows (in an exported reg file):

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\VSS\Providers\{b5946137-7b9f-4925-af80-51abd60b20d5}]
    @="Microsoft Software Shadow Copy provider 1.0"
    "Type"=dword:00000001
    "Version"="1.0.0.7"
    "VersionId"="{00000001-0000-0000-0007-000000000001}"

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\VSS\Providers\{b5946137-7b9f-4925-af80-51abd60b20d5}\CLSID]
    @="{65EE1DBA-8FF4-4a58-AC1C-3470EE2F376A}"

    Best greetings from Germany
    Olaf

    Saturday, October 9, 2010 8:31 AM
    Moderator
  • olaf, I am (slowly) rebuilding the machine back up from a repair install - few more things to do

    All updates (but one) needed to re-install, of course!!!!

    before re-install of connector software and re-try.

    (your win 7 keys above were like mine on win xp)

    will post if this all works or not....

     

    john

    Monday, October 11, 2010 9:15 PM
  • Wish you good luck with that.

    Best greetings from Germany
    Olaf

    Tuesday, October 12, 2010 9:28 PM
    Moderator
  • everyone...

    probelm is now corrected but unfortunately it took a complete re-install of xp pro on new hard drive.  No other solutions worked - not even the repair re-install.

    now to put everything back on the box..............

    I guess this should be marked as closed and sort-of answered...

     

     

     

    Thursday, October 14, 2010 4:19 PM