locked
Error during upgrade from CRM 3.0 to CRM 4.0 RRS feed

  • Question

  •  

    We are attempting to upgrade our CRM 3.0 deployment to CRM 4.0.  The installation and upgrade process fails with an error message:

     

    System.Exception: Action Microsoft.Crm.Setup.Server.InstallDatabaseAction failed. ---> System.Data.SqlClient.SqlException: There is already an object named 'AttributeTypes' in the database.

     

    There is no replication on the database and al the prechecks are "green".  We have not made any unsupported modifications to the CRM system or to the database.  However, we did have a c360 add-on product installed called 'Group Calendar'.  That add-on product was un-installed before the upgrade was performed.

     

    Does anyone have an idea as to what is wrong here?

     

    Sincerely,

     

    Tim Zieger

     

    PS -  Please note, this is the exact same error message that user 'Topaz' posted previously.  We greatly appreciate any assistance.

     

     

    Friday, January 18, 2008 1:33 AM

Answers

  • Hi Tim

     

    I had the exact same Pb with c360 add-on. although I had uninstalled the components. However I had not cleaned all their entities.

    c360 proudly provides a PRE UPGRADE Cleaning tool that removes all their messy stuff prior to upgrade. but if like me you didn't think their program was not properly uninstalling, they do not provide any POST DISASTER help

     

    If you could solve your problem please tell me what path you followed because my CRM is now Down

     

    Regards

     

    Dominique

    Friday, March 7, 2008 12:25 AM

All replies

  • I too received this message.  I was almost feelin' good about my upgrade.

     

    We also have the C360 Core Productivity Pack installed but did not uninstall it.  I know C360 support for CRM 4.0 is not yet available but I don't feel this should have affected the upgrade.

     

    I backed up my log files and re-ran the install.  I selected Repair and it seemed to have completed.

     

    No my organization is stuck in a pending status?

     

    Friday, January 18, 2008 4:38 AM
  • Hi Todd,

     

    Thank you for responding.  Ok, I am feeling like it may have something to do with c360 products.  I wonder if user 'Topaz' installed c360 products in his CRM 3.0 deployment.  I will post a reply to his thread and ask him.

     

    When you wrote "I backed up my log files and re-ran the install", what exactly did you do?  Did you perform a SQL Server backup on your database file?  Or, did you do something else?

     

    Lastly, is you organization still stuck in a "pending status"?  Are things ok now?

     

    I appreciate your assistance.

     

    Thanks,

     

    Tim

    Friday, January 18, 2008 4:56 AM
  •  

    I am using virtual environments to try and upgrade so when the upgrade fails, I revert back to the exact same starting point and re-try.

     

    I seemed to have avoided the AttributeTypes error by simply installing all available Win2k3 updates on both my application server and SQL server (including SP2).  I originally thought it had something to do with c360 as well but I'm not so sure anymore. 

     

    We are running c360 and have not yet received the CRM 4.0 supported version but expecting it this week.

     

    Thanks,

     

    TM

    Wednesday, January 23, 2008 2:27 PM
  • Hi Tim

     

    I had the exact same Pb with c360 add-on. although I had uninstalled the components. However I had not cleaned all their entities.

    c360 proudly provides a PRE UPGRADE Cleaning tool that removes all their messy stuff prior to upgrade. but if like me you didn't think their program was not properly uninstalling, they do not provide any POST DISASTER help

     

    If you could solve your problem please tell me what path you followed because my CRM is now Down

     

    Regards

     

    Dominique

    Friday, March 7, 2008 12:25 AM