locked
deleting custom button on ribbon problem RRS feed

  • Question

  • Hello,

    I am trying to delete a custom button created by ribbonworkbench. I have an issue every time when i make change and try to publish. i receive an error.

    How can i do that?

    Thanks by advance

    Regards

    Monday, August 1, 2016 2:02 PM

Answers

  • hi, thanks, my custom code is ok. i tried to remove all references wirh command before, but i had the same issue, know i remove the solutions, and recreated again it seems ok.

    Regards

    • Marked as answer by dc74 Tuesday, November 8, 2016 8:34 AM
    Tuesday, November 8, 2016 8:21 AM

All replies

  • Greetings dc74,

    To start, what version of CRM are you using? Can you post a picture of the error you are receiving?

    A possibility; since this is a custom button, you may have some Java or other code dependencies that are "looking" for the button you are attempting to remove causing the error.

    We will need some more information to better help with your inquiry.

    Regards,

    Wednesday, August 3, 2016 7:42 PM
  • hi

    Dynamics crm 2015 db 7.0.2.53

    Thanks

    Tuesday, August 23, 2016 1:02 PM
  • Greetings again,

    I had a similar issue when we upgraded from CRM 2011 to CRM 2015, the cause was out-dated Java code.

    Some of the supported java methods/syntax was changed in CRM 2015. We ran the "Code Validation Tool" from Microsoft to ensure our custom code files were up to date:

    Code Validation Tool (CRM 2015)

    In our case, we just kept the custom button and updated the code, your case however, it seems you removed the button but have not removed the Code Library that gave your custom button functionality.

    To elaborate a little on this, in Ribbon Editor, if you select the button in question, you can see all the properties the button has. The "Command" filed is the code method that becomes triggered when the button is clicked:

    1. Remove the Command Reference
    2. Remove the Code Library
    3. Then attempt to remove the Button

    Let me know if this helps, to give more guidance, we will still need more details. If you can provide the exact error messages from the browser and the server we can provide some more trouble shoot steps.

    Regards,


    • Edited by Joseph Kuper Wednesday, September 21, 2016 6:53 PM Picture did not upload
    Wednesday, September 21, 2016 6:52 PM
  • hi, thanks, my custom code is ok. i tried to remove all references wirh command before, but i had the same issue, know i remove the solutions, and recreated again it seems ok.

    Regards

    • Marked as answer by dc74 Tuesday, November 8, 2016 8:34 AM
    Tuesday, November 8, 2016 8:21 AM