locked
WHS/HP MediaSmart default workgroup RRS feed

  • Question

  • Greetings, Wizards of the WHS World.... I recently purchased an HP MediaSmart server. Is it possible to change the workgroup of the box so it matches the rest of my network and doesn't say "workgroup"? Thanks for your help. Cheers, Scot B.

     

    Thursday, December 20, 2007 12:20 AM

Answers

  • Yes, you can change the workgroup name. You'll need to connect to your server using a remote desktop connection, then you'll change the name of the workgroup it belongs to the same way you would for any other PC.
    Thursday, December 20, 2007 1:47 AM
    Moderator
  • Ah, sorry. I assumed you would know how to use Remote Desktop...
    • On XP, Start/Run; on Vista use the search box on the start menu.
    • Type mstsc and press enter.
    • Type your server's name and press enter.
    • Type administrator for the user and the password you set for the administrator when you installed Windows Home Server.
    I assume you can handle it from there. Smile When you're done, don't just close the window. Log off.
    Saturday, December 22, 2007 3:41 AM
    Moderator
  • Really? I ran that once, to create a USB drive with my wireless settings. Smile

    Anyway, in a remote desktop session on the server:
    • Right click My Computer and select Properties.
    • Click on the Computer Name tab.
    • Click on the Change... button.
    • Make sure the Workgroup radio button is selected, and change the workgroup name to match the rest of your network.
    • Click OK then Apply. Reboot.
    Monday, February 18, 2008 7:12 PM
    Moderator

All replies

  • Yes, you can change the workgroup name. You'll need to connect to your server using a remote desktop connection, then you'll change the name of the workgroup it belongs to the same way you would for any other PC.
    Thursday, December 20, 2007 1:47 AM
    Moderator
  • Ken - how do you do that?  I can achieve remote access and get to the HP MediaSmart Server Web Site Remote Access page where there are three tabs: Home, Computers and Shared Folders.  In the Computers tab there is access to the ordinary PCs on my network and the Home Server Console.  How do I achieve a Remote Desktop Connection and then find the control that changes the workgroup name?

    Thanks.

    Miles
    Friday, December 21, 2007 11:38 PM
  • Ah, sorry. I assumed you would know how to use Remote Desktop...
    • On XP, Start/Run; on Vista use the search box on the start menu.
    • Type mstsc and press enter.
    • Type your server's name and press enter.
    • Type administrator for the user and the password you set for the administrator when you installed Windows Home Server.
    I assume you can handle it from there. Smile When you're done, don't just close the window. Log off.
    Saturday, December 22, 2007 3:41 AM
    Moderator
  • Ken - Thanks. It worked.

    Regards, Miles
    Monday, December 24, 2007 11:54 PM
  • Thanks, Ken...That worked Great!

     

    Thursday, December 27, 2007 2:22 AM
  • Ken, et. al.

    Thanks for the good ussgestion.

    But when I try to login via mstsc I get an error message that I cant logon that way since I dont have "Allow Logon through Terminal Server" rights.

    I am already an admin on the Home Server.

    And I have remote access rights.

    Any thoughts?

    Sunday, January 13, 2008 7:28 PM
  •  

    you have to use the built in administrator account  along with the password for you homeserver (the one you set when you initially set it up)....

     

    the account name is "administrator"

     

    the admin user rights granted on the accounts created through the console do not provide sufficient rights to connnect through terminal server (remote desktop connnection).  I would suspect that this type of connection is discouraged since you could cause some serious operability issues if you go fiddling around in there.

     

    joe

    Thursday, January 24, 2008 1:29 PM
  •  

    Joe,

     

    Was surfing for information on this same topic.  I bought an HP Mediasmart server with WHS preinstalled.  I had no problem running mstsc but since the OS was factory installed I didn't set up the password myself.  Any ideas on what the default administrator password might be?

     

    Regards

     

    Mike

    Sunday, January 27, 2008 2:09 PM
  •  

    All,

     

    Just answered my own question.  Was surfing another thread and found a suggestion that was usefull.  I installed Program Launcher Add-in from Red D solutions.  Then went through the WHS console, launched the desktop via the Add-In, then just added my username to the Administrators Group.  This didn't work out so well for me because when I went back to the WHS console I noticed that my name had been removed from photo webshare managers.  The only way I got that functionality back was to delete the user account from the server (luckily I just bought the thing so there wasn't any data on the server associated with the account yet) and then add myself as a user again.  The solution I came up with was to launch the server desktop via the Program Launcher Add In then create an altogether new account on the server OS alone.  Then I added this account to the Administrators group.  Now I can remotely log onto the server using run..mstsc and have full control of the server.  So in the end it was half a morning just trying to change the workgroup on the server but it worked out for me in the long run.

     

    thanks for your time

     

    Mike

    Sunday, January 27, 2008 2:48 PM
  • Ken,

    Can you finish these instructions for those who can't handle it from there
    I currently have two networks, my original network and "WorkGroup" which the HP MediaShare server created for the home server.  As mentioned previously by others, I'd like to have all of my stuff on one network.  Is there any reason why I should move the server out of workgroup and into my home network (a reason other than the fact that I like to be super organized).  Also, If I manage to move the server to my original network, could this cause any problems.  Everything is working fine now, so I probably should leave it alone.  I really wish that there had been a work group option at the time of set up, as it seems this is a bit irritating for others as well.

    Cindy

     Ken Warren wrote:
    Ah, sorry. I assumed you would know how to use Remote Desktop...
    • On XP, Start/Run; on Vista use the search box on the start menu.
    • Type mstsc and press enter.
    • Type your server's name and press enter.
    • Type administrator for the user and the password you set for the administrator when you installed Windows Home Server.
    I assume you can handle it from there. Smile When you're done, don't just close the window. Log off.
    Sunday, February 17, 2008 12:39 PM
  • Nothing will break if you leave the server as it is, and nothing will break if you change the workgroup name to match your other PCs.

    As for changing the workgroup name, you do know how to do that on your other PCs, obviously. Try the same thing in the remote desktop session on your server. Smile
    Sunday, February 17, 2008 3:05 PM
    Moderator
  • Thanks Ken.  When I set up my home network, I used the Network Setup Wizard on each machine.  I don't see that on the server...

     Ken Warren wrote:
    Nothing will break if you leave the server as it is, and nothing will break if you change the workgroup name to match your other PCs.

    As for changing the workgroup name, you do know how to do that on your other PCs, obviously. Try the same thing in the remote desktop session on your server.
    Monday, February 18, 2008 6:56 PM
  • Really? I ran that once, to create a USB drive with my wireless settings. Smile

    Anyway, in a remote desktop session on the server:
    • Right click My Computer and select Properties.
    • Click on the Computer Name tab.
    • Click on the Change... button.
    • Make sure the Workgroup radio button is selected, and change the workgroup name to match the rest of your network.
    • Click OK then Apply. Reboot.
    Monday, February 18, 2008 7:12 PM
    Moderator
  • Thank you Ken, I appriciate your help.  So easy once you know how;-)


    Thursday, February 21, 2008 8:13 PM
  • Thanks so much!!  Great info to know and it worked perfectly Smile
    Friday, July 4, 2008 10:30 PM