none
hpcbpws.ps1, Self-Signed Certificates, and HPCBasicProfile.exe.config RRS feed

  • General discussion

  • I followed the instructions in "HPC Basic Profile Web Service Documentation for CTP2" to create a self-signed certificate. Worked just fine although step 8 is not worded correctly and is confusing.

     

    I then was able to associate the certificate with https protocol correctly although steps 9-12 are unnecessary because hpcbpws.ps1 does it for you.

     

    One problem occurred was when hpcbpws.ps1 went to search for installed certificates, it found none because the version string (I think that is what it is) it was looking for ended in x.x.x.x.x.2 and the self-signed certificates ended in x.x.x.x.x.1. So if you are wondering why it cannot find your self-signed certificates (or other certificates for all I know), it is possible that it is looking for the wrong version number.

     

    Lastly, when I made changes to HPCBasicProfile.exe.config (like removing the comments aroung the logging), I could not start the HPCBasicProfile service anymore and had to uninstall and reinstall since I did not make a backup copy of the file before I started messing with it. I am not sure why removing comments causes such problems, but it did. I used NOTEPAD for the changes.

    Wednesday, May 14, 2008 2:33 PM

All replies

  • The object identifier may be too tighhtly tied to the certificates generated from AD at the moment. Removing that check (the if statement in the powershell) will not filter the certificates and display all  of them in the store.

     

    Removing the comments should not cause the service to crash! There are comments at the start and end of the statement <!-- and --> that need to go. With the logging enabled the output will be written to the file specified at the end of the lgo file... make sure that is valid as well. There is the 'service configuration editor' in the .net SDK which can help with this. 

     

    Steven

    Friday, May 16, 2008 5:59 PM
  • Beta 2 fixes the problem.

     

    Monday, June 2, 2008 12:14 PM