none
Is MCTS 70-515 using 4.0 retired soon ? RRS feed

  • Question

  • Is MCTS 70-515 using 4.0  retired soon  because 4.5 version is much stable since long time ,if any one wants to do MCTS certification then its right time to do or wait for next version exam ?
    Sunday, March 22, 2015 6:13 PM

Answers

All replies