none
Daylight Savings Time Confuses SyncToy RRS feed

  • Question

  • Every spring and fall, many of my files become unsynced by one hour. Manually copying the files does not prevent SyncToy from copying them again.
    Tuesday, March 24, 2009 1:41 PM

All replies

  • Hi -

    Does the problem occur even when you do not manually copy the files? I am assuming one of the sides of your folder pair is a FAT drive. Also, what kind of a sync relationship have you set up ( Echo/ 2 way sync, etc)?

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Tuesday, March 24, 2009 11:54 PM
    Moderator
  • Hi to all. I am having the same problem, or worst!!! Yesterday (march 30) I used SyncToy 1.x for the first time after our daylight changing and it wanted to backup (contribute) all files. I don't know why. Today I upgraded to v.2 but I see that ST sees all files from source path with 2 or 3 hours of difference. What happens?
    Thank you.

    P.S. with the last sync, seems that ST saved last files with an hour less, or all source files have been changed with an hour more. There are untouched files, on source drive, since 2005, so I think that ST saved all files with a difference of 1 hour.

    Tuesday, March 31, 2009 11:46 AM
  • now i am trying to do this

    Q. On the first sync after upgrade from SyncToy 1.4 or 2.0 Beta, where one endpoint is on a FAT16/FAT32 drive (e.g. memory stick or USB key), SyncToy 2.0 wants to re-synchronize all files because the file times look different. What can I do about it?

    hope this helps

    Tuesday, March 31, 2009 1:59 PM
  • Not solved! Even after the first sync file last modified time is 2 hours after real time of modification.
    Tuesday, March 31, 2009 2:37 PM
  • The problem (yes it occurs with all syn tools) is caused by a one hour different timestamp on the USB-Memory stick (FAT), compared to the hard disk (NTFS).

    Seems that I have to change that on the stick.

    By the way: my old syn tool copied "files" being all 4kB from a corrupt FAT usb memory stick to the harddisk....

    Friday, November 2, 2012 7:17 PM
  • This happens when i use sync toy for files going form my NTFS expansion drive that I back up to an NTFS expansion drive.  I keep two identicle copies of a drive to stop me from ever losing photos etc.  This happens each year after the time change going from one to the other.  What ever one is put in the from slot will be at the computer time with a different stamp then the last sync done on the other drive unless i recopy them all (over write) which is insane i would then degrade any jpeg file compression twice a year so I don't overwrite.  

    I use synctoy 2.1 but the 2.0 did also on my xp machine and my vista machine.  My wild guess on why it happens is if you use the quick copy setting (checking the file takes forever), it checks for time differences in the files and overwrites to the newest time, or the time being copied from the left drive to the right drive, and updates the file if it's different.  Seeing the files in the preview on the owerwrite clearly shows the only difference is the time stamp by one hour, they are the same size, created dates, modified dates etc.  This makes Sync Toy almost unusable for me.  If there is some way to fudge this and get the program not to rewrite the files, let me know, this problem has been known and asked about since I started to use SyncToy a few years ago but I have never yet found an answer to it.

    Tuesday, November 6, 2012 6:40 PM
  • Hi

    I also have the same problem I have a ntfs disk partitioned into 3 drives I back up some of the folders to fat32 usb flash (16gb)

    I also have a similar 16gb flash drive (ntfs) after clock change it wants to replace most of the files on one of them I forget which

    I then tried to backup one of the partitions on my hard disk to a folder on my external 1tb ntfs backup drive same thing

    replace loads of files

    Please add a ignore date/time of exact 1 hour difference if size is same

    It is driving me nuts


    • Edited by kenny825507 Tuesday, November 20, 2012 10:05 AM
    Tuesday, November 20, 2012 10:05 AM