none
just stumpped with symbol loading and breakpoints RRS feed

  • Question

  • I'm just posting because i'm stumped.  

    So I'm posting here to see if this looks familiar to anyone. Help? Please?

    I ran into one of those annoying VS things today that steals your productivity. I don't recall making any changes to the code or the project or the website, but today I started getting really strange behavior and now I can't run the debugger. 

    First, here's some vague details:

    --I'm developing a web app that's running through local host on Windows XP (IIS 5.1).

    -- I am working on a "web site", NOT a web project. So I don't have any local binaries. 

    -- because the site has some weird directory mappings,  i can't use Studio's integrated web server, but have to use the localhost (ie, "attach to process" or "use custom server" or something). 

    -- When i hit F5 (or attach to process) everything works, but I get the famous "no symbols have been loaded for this document" warning, and none of the breakpoints work

    -- prior to getting that, I had added a new control onto one of the pages. No matter what I did, the code behind said the control did not exist. I tried recompiling, etc. I even re-named one of the existing controls to force the code to break. When I did that, I'd get the proper error message (ie, the newly mis-named control wasn't found) when I recompiled and when I re-compiled a 2nd time. But the 3rd time I recompiled, I'd get the older error about the new control not existing. SO 2 out of 3 times it gave the right error message, then the 3rd, it reverted to an error that pre-dated the breaking change I made. The only way I got around the issue was to delete the whole page and re-create it with a different name. 

    -- prior to all that, one of my directories in IIS lost its setting and was no longer an application. I'm sure I didn't change it. 

    -- I'm seeing this error in VS2008 and VS2010. 

     

    I've tried:

    -- deleting everything from the "Temporary ASP.Net Files" directory. 

    -- deleting everything from my local files and settings webcache  temp directory

    -- bouncing IIS, restarting studio, rebooting (as mentioned, switching from vs2008 to 2010 didn't help either).

    -- verifying privs on the temp directories. 

    -- I've verified that the web.config is set for debugging (as I mentioned, this all worked last week). 

    -- I've also verified the project's configuration settings, but I don't think that's the issue since it happens in 2008 and 2010 and it's not a web project, but a web site. 

     

    I'm pretty sure that it's a cached assembly that is giving me the problem. Whatever caused the directory to stop being an application must have caused IIS to freak out and leave a dll somewhere. But I don't know where else to look. I really don't want to take a day and reinstall IIS. 

    Anyone have another place I could look or something else I can try?

    thanks

    --kevin

     

    • Moved by Mike Dos Zhang Thursday, January 26, 2012 4:49 AM web dev problem (From:Visual Studio Debugger)
    Thursday, January 26, 2012 12:38 AM

All replies