locked
Is there anyway to tell what specific driver is causing blue screens? RRS feed

  • Question

  • I just re-installed WHS on my server yesterday and the server was working fine all of today but this evening it's started rebooting itself constantly.  This was happening before the re-install but I chalked it up to the system finally being cranky about me replacing the mobo, cpu and ram without re-installing the OS.  That was about 2 months ago.  Turns out it wasn't...

    All the drivers except 2 (NIC and ACPI) were automatically installed with WHS, I got the NIC and ACPI drivers off of the mobo CD.  When the server reboots itself I get 3 separate prompts (3 crashes) to upload a file report to MS for a "serious crash" that is caused by some driver, or series of drivers.  I don't understand why the errors don't just say what driver is causing the problem.  I have no clue how to diagnose it.  I've tried looking in the error logs but they can be hard to decipher.

    I went into the BIOS and noticed that the RAM voltage was set to AUTO, I manually set it to 2.0v (per spec) and also manually entered the timings (5-5-5-15).  I'm now back in WHS, logged in as the admin, and am running Ken's checkdisk script to check all my drives since I'm sure all this crashing has managed to corrupt some data.

    I have a few entries for LoadPerf in my Application error log:

    "The performance strings in the Performance registry value is corrupted when process Performance extension counter provider. BaseIndex value from Performance registry is first DWORD in Data section, LastCounter value is the second DWORD in Data section, and LastHelp value is the third DWORD in Data section."

    Great, but wtf does that mean?

    I also get the following errors in the System error logs with each reboot, Source: System Error:

    "Error code 00000050, parameter1 c30eae00, parameter2 00000000, parameter3 80892115, parameter4 00000000"

    "Error code 1000008e, parameter1 c0000005, parameter2 80892182, parameter3 b966dacc, parameter4 00000000"

    "Error code 0000000a, parameter1 ffe85780, parameter2 d0000001b, parameter3 00000001, parameter4 808312db"

    Those same 3 in the System error log, everytime the system reboots.

    Gee, that's descriptive...

    Up until a few months ago when the original mobo fried I had been having 0 problems with WHS, now it's a constant struggle to keep this damn thing running.  I thought it was all figured and my wife and I were into the last 30 minutes of a movie I was streaming from the WHS to my PS3 when the movie froze...I went upstairs and the damn server was rebooting itself.

    Server specs:
    WHS PP3
    Intel E1500 Celeron Dual Core
    ASUS P5K (BIOS 1006)
    2x1GB Crucial Ballistix 1066
    OCZ SilentXStream 500w PSU
    EVGA 7900GT PCIe
    160GB WD IDE (system)
    2x750GB WD SATA (data pool)
    2x1TB Seagate SATA (data pool)
    1TB WD MyBook USB (backup)

    thanks,
    iain
    Sunday, January 3, 2010 4:05 AM

All replies

  • I when I went to bed the chkdks script was checking the 4 pool drives and I woke up this morning to the sound of the server rebooting and a bluescreen for ntfs.sys page_fault_in_nonpaged_area.
    Sunday, January 3, 2010 3:47 PM
  • I when I went to bed the chkdks script was checking the 4 pool drives and I woke up this morning to the sound of the server rebooting and a bluescreen for ntfs.sys page_fault_in_nonpaged_area.

    First, did your chkdsk finish?  You can see the results in the Applications log in the Event Viewer on the server.  Also, have you tried checking your RAM?
    Monday, January 4, 2010 2:46 AM
    Moderator
  • Yea, after I posted that I ran Memtest on the ram and it returned errors.

    I haven't been back into the OS since I got an nt-something.sys error.  I'm going to take some RAM from work home and see how it goes.  I'll report back.
    Monday, January 4, 2010 6:33 PM
  • Last night I put in 4x1GB sticks of Nanya PC6400 that I had laying around and left Memtest running last night, this morning there were 13 passes with no errors.

    When I get home tonight, if I have time, I'll see if I can boot back into the OS. 
    Tuesday, January 5, 2010 2:33 PM