none
can't access windows home server domain RRS feed

  • Question

  • Hi-

    I setup domain myname.homeserver.com

    Home Server Console tells me I have remote access (web interface) available to the home server and computers on my network

    However, whenever I try to access https://myname.homeserver.com I get a time out or message that the site isn't accessible. I've also tried it with my firewall disabled, so that isn't the problem.

    I have opened the right ports, etc. I can access the home server web interface internally on my network if I use the internal IP address of the homeserver, so I know that the interface is set up and working.

    Any suggestions or comments?

    Thanks
    Wednesday, April 15, 2009 5:15 PM

Answers

  • Investigating my routers log I think I know what the problem is.  You connect to your server via https (port 443) which is opened through your router.  However when you go to the page to connect using a Remote Desktop Connection, it attempts to establish the connection using a dynamic port which your router doesn't have open and therefore will block it and cause a timeout to be returned.  In order for this to work, we would need a static port option for remote desktop through the web page and using the domain name instead of the server name.

    Ken, what do you think?

    For some useful information about how the Remote Access web site works, please read the Remote Access technical brief on the Windows Home Server Help page . In that document you'll find a list of all the ports which need to be open in your firewall and forwarded to your server.

    Something which isn't stated there is that using Remote Desktop by itself to connect to your server is unsupported. By design, you should only use the Windows Home Server console for administrative tasks.

    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by firedog55 Thursday, April 16, 2009 8:51 PM
    Thursday, April 16, 2009 11:23 AM
    Moderator

All replies

  • Have you tested from any locations other than your home? Not all routers can successfully "loop back" to their WAN interface from the LAN interface.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, April 15, 2009 6:07 PM
    Moderator
  • I am having the same problem.
    Thursday, April 16, 2009 2:22 AM
  • Investigating my routers log I think I know what the problem is.  You connect to your server via https (port 443) which is opened through your router.  However when you go to the page to connect using a Remote Desktop Connection, it attempts to establish the connection using a dynamic port which your router doesn't have open and therefore will block it and cause a timeout to be returned.  In order for this to work, we would need a static port option for remote desktop through the web page and using the domain name instead of the server name.

    Ken, what do you think?

    Thursday, April 16, 2009 2:33 AM
  • Just verified this to be the problem.  After placing my server in the DMZ on my router, I was able to access the Remote Desktop using the domain name.  This seems to be a big bug in the software.
    Thursday, April 16, 2009 2:40 AM
  • Just verified this to be the problem.  After placing my server in the DMZ on my router, I was able to access the Remote Desktop using the domain name.  This seems to be a big bug in the software.
    No, that means the software is working fine.  Putting your server in the DMZ removes the router from the equation.  The fact that it worked after removing the router from the equation means the problem is your router (it's not forwarding to the correct IP address).  Either A) your port forward is not set up correctly or B) your router is not working correctly.  (You could try resetting your router back to the factory default and see if that clears it up.)
    Thursday, April 16, 2009 4:49 AM
    Moderator
  • In a home environment a DMZ is usually not available.
    Windows Home Server expects the router being connected like Internet<==>Router<==>LAN, and this is the scenario, which is supported.
    Best greetings from Germany
    Olaf
    Thursday, April 16, 2009 9:54 AM
    Moderator
  • Investigating my routers log I think I know what the problem is.  You connect to your server via https (port 443) which is opened through your router.  However when you go to the page to connect using a Remote Desktop Connection, it attempts to establish the connection using a dynamic port which your router doesn't have open and therefore will block it and cause a timeout to be returned.  In order for this to work, we would need a static port option for remote desktop through the web page and using the domain name instead of the server name.

    Ken, what do you think?

    For some useful information about how the Remote Access web site works, please read the Remote Access technical brief on the Windows Home Server Help page . In that document you'll find a list of all the ports which need to be open in your firewall and forwarded to your server.

    Something which isn't stated there is that using Remote Desktop by itself to connect to your server is unsupported. By design, you should only use the Windows Home Server console for administrative tasks.

    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by firedog55 Thursday, April 16, 2009 8:51 PM
    Thursday, April 16, 2009 11:23 AM
    Moderator
  • Problem resolved.  After opening port 4125 to my WHS I am now able to use the Remote Desktop through the web connection.  Thanks all for your responses.
    • Proposed as answer by ihayesjr Thursday, April 16, 2009 1:05 PM
    • Unproposed as answer by Ken WarrenModerator Thursday, April 16, 2009 2:36 PM
    • Proposed as answer by ihayesjr Thursday, April 16, 2009 3:26 PM
    Thursday, April 16, 2009 1:05 PM
  • Hi-


    Rechecked all the ports and got it working. Thanks.

    Thursday, April 16, 2009 8:50 PM