locked
OpenDNS incompatible with WHS? RRS feed

  • Question

  • Prior to installing Windows Home Server, I was using OpenDNS for my DNS service and their DNS servers were loaded into my router. When I was having trouble connecting my PCs to WHS, I changed the DNS servers to their defaults (my ISPs DNS servers) and I was able to connect and load the WHS console on my PCs. When I tried to add the OpenDNS DNS servers back, I was unable to log into WHS. Is there a reason the OpenDNS servers are not compatible with WHS? I'd appreciate your help.

    Friday, December 28, 2007 6:41 PM

Answers

  • Since there are standards for how these things operate, any "service" that does something different runs a risk of breaking things. In the case of OpenDNS, they break several things. The sad thing is that they supply a theoretically useful service, namely their "net nanny like" filtering service (I think parents should just monitor their young child's internet usage and be done with it, but that's another topic entirely).

    Unfortunately, the families who are most likely to want to try OpenDNS are among those least able to figure out why things break mysteriously when they do. You or I can come up with a solution (and can even recognize the problem pretty quickly), but the OP was mystified until I pointed out that OpenDNS does Very Bad Things™.
    Saturday, December 29, 2007 2:34 AM
    Moderator

All replies

  • Try putting your server in your

    C:\windows\system32\drivers\etc\hosts  file.

    See if that helps.
    Friday, December 28, 2007 7:08 PM
  • Ron, see my reply over here. The short version, though, is that OpenDNS does some non-RFC compliant (therefore non-standard) things when it attempts to "do the right thing" with what it thinks is a mistyped URL or DNS name. You can try adding your server to your hosts file as another poster has suggested, but that creates a maintenance issue; are you going to remember to do that the next time you bring a new PC home? Are you going to do it for every work laptop you occasionally use at home? What about guest PCs? What about non-PC devices (Xboxes and the like)? My honest recommendation is to get rid of OpenDNS.
    Friday, December 28, 2007 8:19 PM
    Moderator
  • Ken,

    Depending on how his DNS is setup he could dynamically register his local machines each time.

    In my case I fixed it on my debian box to dynamically register the machines which I had the search order incorrect and thats why it failed.

    But in order to rule out the problem I added it to the hosts file just to make sure that was it.

    I was just suggesting this as a test/patch more then a solid fix.

    So don't hate me sir heheheh

    Friday, December 28, 2007 8:52 PM
  • Since there are standards for how these things operate, any "service" that does something different runs a risk of breaking things. In the case of OpenDNS, they break several things. The sad thing is that they supply a theoretically useful service, namely their "net nanny like" filtering service (I think parents should just monitor their young child's internet usage and be done with it, but that's another topic entirely).

    Unfortunately, the families who are most likely to want to try OpenDNS are among those least able to figure out why things break mysteriously when they do. You or I can come up with a solution (and can even recognize the problem pretty quickly), but the OP was mystified until I pointed out that OpenDNS does Very Bad Things™.
    Saturday, December 29, 2007 2:34 AM
    Moderator
  • Thanks, Ken and Jon, for your recommendations. Ultimately, while I could edit my hosts file, I don't think the benefits of OpenDNS are tangible enough to warrant the extra effort. I'll leave things as they are since they "just work."

     

    Thursday, January 3, 2008 12:50 AM
  • OpenDNS delivers a faster, safer, smarter and more reliable DNS service. OpenDNS is for resolving external DNS requests, what's often called forwarding.

    (Sorry I'm late to this thread.)

    If you find that due to your network configuration that OpenDNS is trying to resolve internal names, there is an easy solution: add a "typo exception" so our servers know not to attempt to resolve it. http://www.opendns.com/support/article/164 has details.

    Fixing problems that computers can help with, like fixing microsoft.cmo to microsoft.com, is improving the DNS. We start with speed and reliability, and add intelligence like phishing prevention, typo correction and optional content filtering. OpenDNS is a choice, and 3 million people have made that choice, which is why we're resolving nearly 4 billion requests a day.

    We want to make it easy to use OpenDNS in all situations, so I welcome feedback about how we can improve our service for the WHS platform.

    John Roberts
    OpenDNS
    http://www.opendns.com/


    Thursday, January 3, 2008 1:57 PM
  • John, the typical home network doesn't actually use an internal domain, per se (though one effectively does exist). Most home networks manage their internal name resolution through NetBIOS, not DNS. The problem that OpenDNS creates for these users is that DNS resolution is attempted before NetBIOS resolution. If OpenDNS didn't try to resolve e.g. SERVER to whatever it tries to resolve it to, and just let it fail (which is what I remember the RFCs dealing with DNS requiring), then everything would work fine.

    The best way to make OpenDNS easy to use would be for you to set up Windows Home Server in a lab, where you can recreate a range of typical home networking environments with a variety of Internet connections, and figure out exactly what a home user must do to get everything working correctly. (Well, that and following the appropriate RFCs; though RFCs are often treated more as guidelines than actual rules, they do set de facto standards.) You can obtain 120 day evaluation software from Microsoft or buy a full licensed version from a number of online retailers.
    Thursday, January 3, 2008 5:40 PM
    Moderator
  • OpenDns will cause bare metal restores to fail.  You will be prompted to enter your password, but you will immediatley get a network failure message.

     

    Switching back to conventional DNS instantly cures the problem.

    Monday, January 7, 2008 7:07 PM
  • John

     

    My suggestion is not to reslove hostnames without domains unless it is an explicitly defined user shortcut. A second option is to instruct users to configure their resolution search order so that DNS is last.

     

    To anyone else that is listening, my suggestion is not to use OpenDNS.

     

    Wednesday, January 9, 2008 3:32 PM
  • Just thought I would bring an easy fix to the table.

    I use OpenDNS and also had this problem.  If you go to OpenDNS.com - manage - settings and uncheck the boxes under Domain Typos it fixes the problem.  No need to and your network to the VPN exceptions list.

    Hope it works for everyone else like it did for me!
    Monday, April 13, 2009 12:45 PM
  • Zach, have you attempted a bare metal restore? Note that other users who have, have found that OpenDNS interferes with that process. I believe from other threads that this includes users who have set up exceptions, etc.

    If you have, and have been successful, could you write your procedure up, step by step, as a "how to" for others to follow? I'll be happy to test and post in the FAQ section with proper attribution. :)

    I'm not on the WHS team, I just post a lot. :)
    Monday, April 13, 2009 3:07 PM
    Moderator

  • It's Typo Correction, remember http://social.microsoft.com/Forums/en-US/whssoftware/thread/efe9f794-21b7-4d4e-8c73-9d7a225c6a5f

    1. Use OpenDNS settings in home router.
    2. Disable Typo Correction in OpenDNS settings.
    3. Live happily.

    Backups, restores etc. all working fine after disabling Typo Correction.
    • Proposed as answer by sh1ft3rdotcom Monday, April 13, 2009 6:48 PM
    Monday, April 13, 2009 6:47 PM
  • I have not had to try a bare metal restore as of yet.  I would be nice to know if it works, but I don't have the time to test it right now.  Maybe someone could try it and post here to let us know!
    Friday, April 17, 2009 4:38 AM
  • Turned off Typo Corrections.
    That worked.

    Thanks a bunch.

    Bob
    • Proposed as answer by Bob Millard Sunday, December 6, 2009 10:32 PM
    Sunday, December 6, 2009 10:31 PM