locked
Office Communicator R2 FAILS to start IM conference (ID:504) RRS feed

  • Question

  • Hello!

    Conditions:

    Windows Server 2008 R2 (build 7600 RTM)
    Office Communications Server 2007 R2 Standard
    All Services Started well
    IM Conferencing started (port 5062)


    Office Communicator Version 3.5.6907.37

    Problem:

    When i'm trying to start conversation with more than one contact (IM conference) i've got an error in communicator window:

    An error occurred while trying to start the conference. More details (ID:504)
    The following message was not delivered to all participants. More details (ID:504)

    When i'm trying to share desktop in such a session i've got:
    Application Sharing could not be started because an error occurred. More details (ID:504)

    Diagnostic:
    Vista (windows 7, server 2008 R2 the same result) client's Event Log after trying to start IM chat:

    A SIP request made by Communicator failed in an unexpected manner (status code 80ef01f8). More information is contained in the following technical data:
     
       RequestUri:   sip:cahek@domain.local;gruu;opaque=app:conf:chat:id:24D8969F251FD847BCEE171453F45DFC
    From:         sip:cahek@domain.local;tag=f35e242872
    To:           sip:cahek@domain.local;gruu;opaque=app:conf:chat:id:24D8969F251FD847BCEE171453F45DFC;tag=C90B627E6A1ED0F3BA0C88625C0EA54A
    Call-ID:      c19c9efce2cf44e591c0b7a5fe64ff2d
    Content-type: application/sdp;call-type=im

    v=0
    o=- 0 0 IN IP4 192.168.0.111
    s=session
    c=IN IP4 192.168.0.111
    t=0 0
    m=message 5060 sip null
    a=accept-types:text/plain multipart/alternative image/gif text/rtf text/html application/x-ms-ink application/ms-imdn+xml text/x-msmsgsinvite


    Response Data:

    504  Server time-out
    ms-diagnostics:  1007;reason="Temporarily cannot route";source="vm-cWin2008R2.domain.local";ErrorType="Failure reading or writing data on connection";WinsockFailureDescription="The peer forced closure of the connection";WinsockFailureCode="10054(WSAECONNRESET)";Peer="vm-cwin2008r2.domain.local"


     Resolution:
     If this error continues to occur, please contact your network administrator. The network administrator can use a tool like winerror.exe from the Windows Resource Kit or lcserror.exe from the Office Communications Server Resource Kit in order to interpret any error codes listed above.

    ANY SUGGESTIONS?
    • Edited by prinzc Wednesday, July 29, 2009 10:28 PM
    Wednesday, July 29, 2009 1:59 PM

All replies

  • This problem is general for all conferencing (audio, video, IM, AppShare)

    Server Tracing Results (Trace Log analysis by Resource Kit) :

    After each try to start conference 3 "Red" events:

    TL_ERROR(TF_CONNECTION) [0]1FF4.120C::07/29/2009-18:30:01.187.00008824 (SIPStack,SIPAdminLog::TraceConnectionRecord:SIPAdminLog.cpp(157))$$begin_record
    LogType: connection
    Severity: error
    Text: Receive operation on the connection failed
    Local-IP: 192.168.0.116:18849
    Peer-IP: 192.168.0.116:5062
    Peer-FQDN: vm-cwin2008r2.domain.local
    Connection-ID: 0x4300
    Transport: TLS
    Result-Code: 0x80072745 WSAECONNABORTED
    $$end_record

    TL_ERROR(TF_CONNECTION) [0]1FF4.120C::07/29/2009-18:30:01.187.00008825 (SIPStack,SIPAdminLog::TraceConnectionRecord:SIPAdminLog.cpp(157))$$begin_record
    LogType: connection
    Severity: error
    Text: The connection was closed before TLS negotiation completed. Did the remote peer accept our certificate?
    Local-IP: 192.168.0.116:18849
    Peer-IP: 192.168.0.116:5062
    Peer-FQDN: vm-cwin2008r2.domain.local
    Connection-ID: 0x4300
    Transport: TLS
    $$end_record

    TL_ERROR(TF_DIAG) [0]1FF4.120C::07/29/2009-18:30:01.187.00008827 (SIPStack,SIPAdminLog::TraceDiagRecord:SIPAdminLog.cpp(140))$$begin_record
    LogType: diagnostic
    Severity: error
    Text: Message was not sent because the connection was closed
    SIP-Start-Line: INVITE sip:vm-cWin2008R2.domain.local:5062;transport=tls SIP/2.0
    SIP-Call-ID: ab29ec8875034496a6b095710bdad114
    SIP-CSeq: 1 INVITE
    Peer: vm-cwin2008r2.domain.local:5062
    $$end_record

    Wednesday, July 29, 2009 6:35 PM
  • Maybe there is some problem with certificates (but it seems to me to be OK)

    And i dont understand why there is the same IP in both Local-IP and Peer-IP (this is IP of OCS 2007).

    Local-IP: 192.168.0.116:18849
    Peer-IP: 192.168.0.116:5062

    Could someone explain?
    Wednesday, July 29, 2009 7:59 PM
  • Who is the certificate issued from?  If this is from a Public CA, then I have seen this issue when the Root Certificate is not configured to support all purposes.  Also if there is any CRL issues this can happen.  Is there any Edge Servers in this enviroment?

    Geoff
    Thursday, July 30, 2009 2:36 AM
  • Certificate was issued by Domain Standalone CA (installed on the same server as OSC)
    Enhanced key Usage: Server Authentication, Client Authentication

    No Edge Servers in the enviroment
    Thursday, July 30, 2009 4:36 AM
  • Hi

    Check if recent updates have been done on OCS servers, if so Ask to MS PSS because QFE2 introduced bug in SIP layer that has this kind of impact. Another QFE is ready since couple of days.
    Monday, August 3, 2009 8:35 AM
  • Its looks like Certificate issue. Please make sure you got your Root CA on all the clinets where you are testing this and make sure in communicator you give Pool FQDN at the advanced Connection Settings.


    Jithendranath Reddy
    Monday, August 3, 2009 8:56 AM
  • hi,
    have you found a solution for your case?
    I have the same problem in a lab. As everything is working fine I think the certificate is not the origin of the problem in my lab but the same error will be logged as soon as I start group chat by clicking meet now....
    any idea?
    Tuesday, August 25, 2009 10:34 AM
  • Error 504 typically indicates a network connectivity error; are their any filtered ports (firewalls) between the communicating parties? (3-party or more conversations include communications with the Front-Een server are not peer-to-peer).
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Tuesday, August 25, 2009 2:55 PM
    Moderator
  • Since it is a lab there is no firewall configured (they are all turned off) and all the machines have full network connectivity with each other. Other services on OCS are working all fine.
    I double checked on OCS server (standard installation on a s single server) and the port 5062 is in listening mode. Additionally i monitored the TCP activities on my test client and noticed when I click on meet now my client doesnt try connecting itself to port 5062 (default IM confressing port). the same happens on all other test clients.

    Additional Information:
    I just installed the MS-Communicator on OCS server and started IM Confressing. Again the error code 504 was appeared but this time in eventlogs I have some additional information:

    <from log>
    Response Data:

    504  Server time-out
    ms-diagnostics:  2;reason="See response code and reason phrase";source="OCSServer.blabla.local";HRESULT="0xC3E93C69(SIPPROXY_E_CONNECTION_FAILED)"
    </from log>

    according to lcserror.exe from resource kit it means: "The connection over which the message was sent has failed."
    any idea now?

    Wednesday, August 26, 2009 11:40 AM
  • Hi,

    we are experiencing same error at our production environment. I have installed OCS R2 in lab and there is everything OK. There is just one difference between LAB and production - it's Windows 2008 version. In lab we have Windows 2008 Datacenter and in production we have Windows 2008 R2 Datacenter.
    Thursday, August 27, 2009 11:12 AM
  • In lab I am using win 2008 R2 as well. could R2 be the origin of problem?

    Thursday, August 27, 2009 11:30 AM
  • It could be. Who knows. Probably I will try to reinstall OCS to W2008.
    Thursday, August 27, 2009 12:49 PM
  • Yes, OCS is not supported on Windows Server 2008 R2.  No supportabilty statement has been released yet.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Thursday, August 27, 2009 1:11 PM
    Moderator
  • Hi
    Per my known.
    Ocs 2007 r2 is not fully supported by the windows 2008 r2.

    Regards!
    Thursday, August 27, 2009 1:46 PM
    Moderator
  • I installed again on a server 2008 and IM confrencing works fine. so there sould be an issue regarding to R2 and IM confrencing.
    thank you guys for your support.
    Thursday, August 27, 2009 2:11 PM
  • I have finished reinstall as well (Windows 2008 SP2 Datacenter) and everything works fine. Thanks for support.
    Thursday, August 27, 2009 3:46 PM
  • Hi everyone. I am having a similar problem with the same setup ...

    Windows 2008 server R2 and OCS 2007 R2

    When I try to do a live meeting everything works (presentation, all application sharing including changing person in control) .. but .. Audio and Video does not work

    From my investigations this is due to some problem in the OCS MCU and I do believe that it has something to do with Windows 2008 R2 (as I had a very similar setup working in a windows 2008 environment).

    I can paste more info if someone wants to investigate but my logs and traces are pretty much the ones pasted up here in this post already ....

    Does anyone knows if MS is going to release a patch or anything that will make OCS R2 work in windows 2008 R2 ? (If this is the problem which I believe it is)

    Thanks

    Nuno Ferreira
    Wednesday, September 9, 2009 12:21 PM
  • Hi Nuno,
    I am not an expert and cannot help you in details, but according to my experience there are problems when u install OCS on server2008R2. For sure MS will release the required patches, till the patch realease I recommend you to forget server2008R2 and enjoy or OCS on a server 2008:)

    regards,mt
    Wednesday, September 9, 2009 9:24 PM
  • Hi @all,

    I experienced the same issue and on the comments made here in this thread I decided to reinstall in Windows 2003 R2 64 bit (because I hoped the VM will use less disk space and less RAM then a W2K8). On W2K3R2 the issue is solved and I can do a audio conference with 3 clients with no problem.

    Thx to people answering this thread for pointing me in the right direction.

    Cheers,
    Daniel
    Sunday, September 13, 2009 10:00 PM
  • I had the same issue on Server 2008 R2 so I created a new virtual machine of Windows Server 2008 x64, and install OCS 2007 R2 and 3-party IM worked flawlessly. =D I spent about 8 hours trying to figure out what the issue was.
    Friday, September 18, 2009 9:17 PM
  • It is absolutly crazy that 2008 R2 and Communicator 2007 R2 is not compatible. I am going to create a microsoft ticket and hopefully get an answer for everyone here.

    You say there is no supportablilty statement, there is also no UN supportablity statement.

    Derek
    Thursday, October 1, 2009 4:00 PM
  • I can already give the answer you'll get from PSS:  Changes to how SSL works, among others in Server 2008 R2 cause some of the OCS R2 functionality to not work correctly.  Microsoft is currently testing OCS on Server R2 and they hope to have a supportability statement released sometime round the end of the year, but that depends on the amount of changes needed (if possible) to get OCS to support that server platform. 

    Realize that Server 2008 R2 has launched after OCS R2 was already completed and released.  It's not realistic to expect that a product would work 100% on an operating system that did not exist in that form when the product was written.

    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Thursday, October 1, 2009 5:12 PM
    Moderator
  • It is absolutly crazy that 2008 R2 and Communicator 2007 R2 is not compatible. I am going to create a microsoft ticket and hopefully get an answer for everyone here.

    You say there is no supportablilty statement, there is also no UN supportablity statement.

    Derek

    I agree, and I hope Microsoft can help us out here soon.
    • Proposed as answer by h123max Thursday, November 5, 2009 5:05 PM
    Tuesday, October 6, 2009 2:02 PM