locked
Port forwarding problems after recent upgrade for remote security RRS feed

  • Question

  • Last week got a message that security was upgraded for remote access and that all I had to do was to basically shut down and restart remote access.  Everything seemed fine at first.

     

    Then I started getting port forwarding error messages.  Checked local and remote connections and all was fine.  Recycled remote connection and error went away.  Fixed problem, but then it keeps coming back every 10 minutes or so.

    Has the new security broken the port forwarding in some way?

     

    BEFORE YOU RESPOND - be aware that:

    1. This WHS has been running for 2 years with no similar problem

    2. Everything in the network is the same - Comcast cable router, WRT54G router, multiple servers but DHCP is on the router

    3. I've read all and tried all of the suggestions to fix this such as static addresses, manually port forwarding, upgrading router firmware, etc.  I have not tried reloading WHS yet.

    Monday, September 6, 2010 2:54 PM

All replies

  • I would like to know this too... something has completely locked down the system... thinking the same thing.
    Monday, September 6, 2010 6:04 PM
  • Addendum:

    Thought that things were running fine until I got a call and tried going beyond the log on splash screen.  After logging in I'm routed to my router IP at 192.168.1.1 instead of my WHS server at 192.168.1.15.  It seems as though something in the new "secure" setup is either broken or is breaking the port forwarding in the router.  Could very be why I'm getting the port forwarding error message as well.

    Have not been able to get further in diagnosing the problem - ideas anyone?

    Monday, September 6, 2010 8:20 PM
  • Addendum 2: At least have a workaround, but it means that you lose remote mgmt on your router.  I don't know what has changed, but it appears that subsequent WHS messages are coming in on port 80.  Since that was where my router was set up for admin and when I turned off remote mgmt after looking at the inbound router log (note that you can't use anything but port 80 on the WRT54G) everything is working at least as far as getting in remotely to WHS.  Have turned port forward checking back on and will see if I still get an error.

    So I'm surmising, but it look like the new "secure" function has wiped out my ability to use remote management on the router.  Suspect there's a bug here.

    Monday, September 6, 2010 10:32 PM
  • Addendum 3:  Port forward checking is all happy.  Reviewing router logs shows the homeserver.com is routing all port 80 messages to the router ip and not the server ip.  Something is broken with homeserver.com, but at least this is a workaround.
    Monday, September 6, 2010 11:25 PM
  • What you're describing is a router problem. If packets for IP address A.A.A.A (your server) are actually going to A.A.A.1 (your router) then look to your router for the source of the trouble, because it's your router that determines where a packet actually goes.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, September 7, 2010 1:10 AM
    Moderator