locked
Subjects misbehaving in CRM 2013 odd issues with dropdowns on Case RRS feed

  • Question

  • We are getting weird behavior with subjects on our Case form after upgrading to CRM 2013. I'm not sure how this is happening but it has something to do with Subjects. The Case Type and Subject fields are managed so we're unable to remove and read and I'm just seeking direction on where we should start troubleshooting something like this?

    I've included some screenshots of the behavior and note that some of the items showing are not even in Subjects but they are coming up in the drop down as well as the company drop down on our Case entity.

    Friday, March 14, 2014 9:22 PM

All replies

  • I suspect you have some kind of javascript that is intended to filter the Case Type picklist, maybe based on another field.

    Perhaps the form was redesigned and that other field is now after, rather than before the Case Type? Or the script was written in an unsupported way that now breaks in 2013?

    I can see you have two fields called Case Type and Type on the form - what are the schema names of these? Is one of them a custom field, or just renamed? What script events are associated with these and with the Subject field?


    Hope this helps.
    Adam Vero, Microsoft Certified Trainer | Microsoft Community Contributor 2011
    UK CRM Guru Blog

    Sunday, March 16, 2014 10:48 AM
  • The field that is misbehaving is systemname "SubjectId", and is not a custom field. Yes, the displayname was renamed to "Case Type". The other Case Type field was added to the form from upgrade and is the schemaname "CaseTypeCode". "SubjectId" is the misbehaving field though. I understand the suspicion of custom javascript, but we have no custom javascript on the case form nor quick create. No javascript events on the field itself either - there are literally no javascript resources (or any web resources for that matter) on this form. 

    The issue occurs on the quick create form and the normal case form - any form that has this field on it. 

    Further, on the case form it acts even more bizarre, cause the account dropdown to populate with the Subject contents, noting that the hierarchy of the data is also not correct here. (see below)

    We tried re doing the upgrade of our production organization again to see if the problem still persists - didn't make a difference and we still have the same result. 

    I'd also like to add and point out that some of the values being populated in the dropdown aren't even in our subject tree any longer. Some of the items had been removed several months ago. You can also see the the hierarchy is really malfunctioning - there doesn't appear to be any rhyme or reason to it, it's just haphazardly placing subjects at random places in the hierarchy. 

    I tried modifying the subject tree. Changes do the subject tree do not even seem to affect the list here; i tried adding items, but they did not show up in any place of the subject tree for this dropdown. 

    On a hunch I tried removing any subjects with special characters, but no luck. I tried moving the subject field elsewhere, no luck - company dropdown is still affected the same way. I would try to outright remove the subject field, but it is a managed field labeled as required and CRM will not allow it to be removed. 

    

    




    • Edited by mark.0 Monday, March 17, 2014 6:12 PM
    Monday, March 17, 2014 3:59 PM
  • WOW!

    That is seriously broken!

    Can you create a new form for the Case entity and see if that has the same issue?

    Can you remove (save, publish) and re-add the Company field (save, publish) and see if that makes any difference?

    Have you tried this in other browsers, such as Chrome? What browser is this issue arising in, out of interest?

    This might be worthy of a support call to Microsoft at this stage.


    Hope this helps.
    Adam Vero, Microsoft Certified Trainer | Microsoft Community Contributor 2011
    UK CRM Guru Blog

    Monday, March 17, 2014 7:23 PM
  • We can't remove the subjectid field because it is required and we have removed the company field then republished to no avail. It's doing this in Chrome as well and I think it might be a database issue during our upgrade possibly as some of the subjects it brought in were old and removed before the upgrade.

    Unfortunately I think you are right in a call to Microsoft may be in order...



    • Edited by PSImonSays Monday, March 17, 2014 8:01 PM
    Monday, March 17, 2014 8:00 PM
  • The Account lookup being broken makes it look like a form issue

    Have you tried a new form from scratch (not even using Save As)?

    Do existing records display the Account correctly?


    Hope this helps.
    Adam Vero, Microsoft Certified Trainer | Microsoft Community Contributor 2011
    UK CRM Guru Blog

    Tuesday, March 18, 2014 9:58 AM
  • Yeah, we did try creating a new form without success. 

    I did notice that if the field is moved AFTER the account lookup field, the account field lookup is no longer broken; so it seems that every dropdown thereafter in the markup is what gets affected. 


    • Edited by mark.0 Tuesday, March 18, 2014 3:39 PM
    Tuesday, March 18, 2014 3:38 PM
  • Hi Mark,

    Thank you for using Microsoft Forums. I have tested the scenario you have descripted in a vanilla CRM Online organization and I wasn’t able to reproduce the issue with the sample database - the Subject field and the Type field  values are populated in an alphabetic order as defined in the Fields Properties. I was also able to successfully add new items to both fields and then use them to create a new case.  

    I understand that you run a numbers of tests to address the issue, including deleting and recreating the values for the Subject and the Type fields to address the issue. If I misunderstood you and these steps are were not yet applied, I recommend you to try so.

    As you have identified a relation of the issue with the Account lookup field, you might want to try to disable the “Disable the most recently used items” for this field and test again the behavior.

    If these steps don’t help you address the issue, I’d recommend you to open a Support Request with CRM Technical Support and work with our team on the issue.

    Please let us know if this helps.

    Thank you.

    Nina Peneva

    CRM Support Engineer

    Wednesday, March 19, 2014 4:02 PM
  • Thanks, yes we've opened a case with a Microsoft representative to elicit a resolution. We're currently trying to recreate the problem by importing our solution into their environment to troubleshoot further. 
    Wednesday, March 19, 2014 5:31 PM
  • Hi Mark,

    many thanks for the update. I am very glad to hear that you are already working with CRM Technical Support on the issue.

    Thank you for using Microsoft Forums.

    Nina Peneva

    CRM Support Engineer.

    Thursday, March 20, 2014 5:14 PM