locked
Application hang on voice call with Linksys WRT54G Wireless Router RRS feed

  • Question

  • I have Office Communicator running through a Linksys WRT54G (ver. 6) Wireless Router.  When I make a PSTN call it will signal and ring the phone but when the attempt to connect the call is made OC hangs and the call fails.

     

    Windows Live Messenger works fine with audio.

     

    Live Meeting works with audio and video.

     

    PC-PC calls work sometimes and fail in the same behaviour other times.

     

    If I bypass the router, and connect directly to my cable modem, all scenarios work fine.

     

    I have all default settings on the router and the latest firmware (1.02.2).

     

    Windows Firewall is on, on the PC, though turning it off has no effect.

     

    I have disabled my ISP-provided firewall desktop software (F-Secure) as well.

     

    I've tried port forwarding etc. on the router but to no avail.

     

    Has anyone else experienced this behaviour?  Any ideas on what might be causing this?  This is a very popular router so I really need to get this sorted!

     

    Thanks,

    Mark

    Tuesday, January 8, 2008 3:15 PM

All replies

  • Update:

     

    I just bought both a brand new WRT54G (Ver. 8) and a WRT150N to see if it was just my particular router.  No luck.  Calls still will not connect with either router (fresh out of the box, no security).  One difference is that the OC client does not hang -  I just get "call was disconnected".  That could be the machine -- these last two trials are off a notebook, while the application hang is on my desktop.

    Friday, January 25, 2008 2:01 AM
  • I have the same issue, did you ever get a resolution?

     

    Friday, July 25, 2008 1:51 AM
  •  

    Are you still having this issue?  I have a WRT54G at home and do not have problems with PSTN calling.  It sounds like a problem with your A/V edge server.  Are you able to make calls from anywhere else on the internet other than your office?  Are you using a VPN solution to get onto your network?
    Monday, July 28, 2008 7:26 PM
  • With my old Dlink router it wasnt an issue.

     

    Monday, July 28, 2008 10:21 PM
  • I use OCS via Edge at home on a daily basis with a WRT54GC, which is the compact version of the same router.  Have you tried another unit of the same model to rule out a hardware/ROM issue?
    Monday, July 28, 2008 10:33 PM
    Moderator
  • Actually I have a WRP400 Linksys router.  I use it with an OCS Edge server and mediation server with a Dialogic 1000 series gateway at the corporate office.  Seems everyone with Linksys routers have the same issue.  A straight communicator call works.  Its only when making a call via the PSTN network.  PC--->Edge Server----->Mediation Server----->Gateway---->PSTN.

     

    Monday, July 28, 2008 11:43 PM
  • Dumb question: are you sure that your A/V edge server has a publicly routable IP address? The behavior that you describe is very, very similar to what happens when you have a NAT'd IP address on the A/V Edge. I noticed that sometimes it works, sometimes it doesn't with the NAT'd IP.

     

    Regards,

    Matt

     

     

     

    Tuesday, July 29, 2008 12:03 AM
  • Yes we have a publicly routable address assigned to the Edge Server for A/V. 

     

    If I place my laptop into the DMZ on the Linksys router it works fine.  Same if I plug the cable modem directly into the laptop.  This tells me that the A/V Edge configuration is fine.  There is definately an issue with the Linksys router passing audio traffic for whatever reason.  All the users having the same issue have Linksys routers of different models.

    Tuesday, July 29, 2008 12:10 AM
  • Sorry Jack... I know this part is frustrating..  Is your Linksys acting as a firewall as well?  I dont have mine configured as a firewall and have the following configuration on the security page:

    Block anonymous internet requests = checked

    Filter Multicast = checked

    Filter Internet NAT Redirection  = uncheck

    filter IDNET (port 113) = checked

     

     

     

    Tuesday, July 29, 2008 12:55 AM
  • My router is configured exactly the same with the firewall OFF.

     

    Tuesday, July 29, 2008 1:05 AM