locked
Duplicate Activities being created after Exchange Sync in CRM 2013 On-Premises RRS feed

  • Question

  • Hi all,

    I've found an unusual issue where when we sync a user for the first time using Exchange Sync in CRM 2013 (SP1 RU1) on premises in some cases their Activities are duplicated, sometimes just a few duplicates but sometimes hundreds are created.  For example I created an Activity on a user on '2015-06-08 15:28' then setup Exchange Sync for the user in CRM.  After this we had 11 duplicates created for this PhoneCall the first one Created On '2015-06-08 16:13' then new ones created about every 24 minutes until '2015-06-08 20:00'.  Finally another one was created the next day at '2015-06-09 08:01'.  I can identify the duplicate Activities because they have SubscriptionID populated and the original Activity has a null SubscriptionID.  Also though these were just about 24 minutes apart we had one instance where thousands were created milliseconds apart of each other.

    I was able to tie the SubscriptionID's back to the SyncEntry table, and all the entries have a SyncState of zero.  Also the new duplicated entries all have the same CreatedBy and ModifiedBy values as the original Activity, but I know for a fact the user didn't create them.  

    Has anyone seen this or maybe know enough about the ExchangeSync to know what may cause duplicates like this?  We are able to recreate it, but we're at a loss on what's causing it.  And it's not occurring for all users, though I'm unable to find any difference in setup between those where it has happened and those where it didn't.

    Thanks.

    Tuesday, June 9, 2015 6:27 PM

All replies

  • Hi Sam,

    did you manage to figure out what was causing these duplicates in the system?

    We have been seeing the same behavior as you are describing on a CRM 2011 environment. 

    Monday, September 28, 2015 3:07 PM
  • No we still haven't found a solution. I've had an open incident with Microsoft for a few weeks now working through it, and they haven't been able to find a fix either.  I just last week sent them a copy of our organization database, and they're testing it.  I haven't heard back on what they've found, but I'll contact them today with an update and post when I know more.

    Take care --

    Monday, September 28, 2015 5:08 PM