none
Does Sora 802.11's ACK mechanism works? RRS feed

  • Question

  • Hi,all

    I read the 802.11 mac code. And I find that it has defined all the ACK mechanism. But when I use UDP to test the tx/rx,

    I find the ACK structure doesn't works.

    So I want to ask if the ACK mechanism can work successful.

    Thanks a lot.

    Tuesday, February 22, 2011 1:14 AM

Answers

  • Hi Albert,

    The ACK mechanism should work. So, please diagonsis more into your system setting to see what is going on there.

    For example, can you install a MAC layer sniffer to see if any ACK frames are sent out?

    Or does the node actually can send out any frames?

    And also check your IP setting. Is ARP correct?

    And some basis, you should always use free build for the online test.

    Unless you provide more information, we have no idea on what has happened.

    Thanks,

    - Kun

    • Marked as answer by Albert CAO Wednesday, March 2, 2011 1:10 AM
    Monday, February 28, 2011 2:38 PM

All replies

  • Did you try udp broadcast?

    If PHY ACK does not work, TCP can never work.


    Sen Xiang (项森)
    Wednesday, February 23, 2011 2:04 AM
    Moderator
  • Hello, Sen Xiang,

    I have tried udp broadcast and it is successful.

    However, in the mac layer's code, broadcast needn't ACK. When I test the udp unicast with iperf, the communication always failed.

    Can you help me to fix this problem?

    thanks.

    Wednesday, February 23, 2011 6:49 AM
  • Hi Albert,

    The ACK mechanism should work. So, please diagonsis more into your system setting to see what is going on there.

    For example, can you install a MAC layer sniffer to see if any ACK frames are sent out?

    Or does the node actually can send out any frames?

    And also check your IP setting. Is ARP correct?

    And some basis, you should always use free build for the online test.

    Unless you provide more information, we have no idea on what has happened.

    Thanks,

    - Kun

    • Marked as answer by Albert CAO Wednesday, March 2, 2011 1:10 AM
    Monday, February 28, 2011 2:38 PM
  • hello, Tan,

          Thanks for your  help. I reset the ARP to bind the static mapping table. And using the UDP unicast to test the Sora. And the ACK mechanism works.

    Thanks a lot.

    Wednesday, March 2, 2011 1:09 AM