locked
cannot delete site RRS feed

  • Question

  • Hello,

    I have made a new site in CRM 4.0, even if I did not add any other informations that may be linked (resources etc), I cannot delete it, I get a general error.

    What may be the problem ?

    Thanks,

    Monday, December 6, 2010 3:08 PM

Answers

  • Ok, now I understand what you mean by 'site' :).

    First of all, I would suggest you take a look at eventlogs (from CRM server and SQL Server). This may point you to additional information so as to understand the cause and solve the problem.

    Then I strongly recommend you update to latest rollup (at this moment, rollup 14).

    If problem persists, I would give CRMDiagTool 4 a try. This could be very useful in case you are still having the problem.

    If yet the problem is still there, I would download Bulk Delete tool. Despite this tool is thought for bulk delete scenarios, I think you can use it for deleting only one record.

    I honestly think (and hope) that at this point you've already solved the problem. If not, I would follow MayakanP's suggestions.

    Hope this help, please keep us posted.

    PP


    Microsoft MVP Dynamics CRM | My Twitter: http://twitter.com/pabloperalta | My blog: http://weblogs.asp.net/pabloperalta
    Tuesday, December 7, 2010 1:35 AM

All replies

  • Hello, what do you mean by a new "site"? Do you mean that you created a new organization using the Deployment Manager and now you want to delete it but can't? If so, please enable tracing and look in the trace log files for more details of the error message.

    Regards, Neil


    Neil Benson, CRM Addict and MVP at Customery Ltd. You can reach me on LinkedIn or Twitter. Join over 10,000 other CRM professionals on the Microsoft Dynamics CRM group on LinkedIn.

    Monday, December 6, 2010 3:55 PM
    Moderator
  • hey, sorry, just replied to your previous post.

    i can see Neil's is asking for similar info.

    Please help us help you :). please explain it a little further..

    What exactly did you create? an organization?

    how are you attempting to delete it?

    Is this the first time you install CRM?

    thanks,

    PP



    Microsoft MVP Dynamics CRM | My Twitter: http://twitter.com/pabloperalta | My blog: http://weblogs.asp.net/pabloperalta
    Monday, December 6, 2010 4:27 PM
  • Hello,

    By site I mean new office locations (settings-business management-sites).There is a delete button there.

    Thanks

    Monday, December 6, 2010 9:19 PM
  • you need to devlope custom workflow as per David's solution

    http://crmentropy.blogspot.com/2010/11/delete-this-record-custom-workflow.html

    or you could apply solution similiar to what Andriy did for deleting team in following article..

    http://a33ik.blogspot.com/2010/05/delete-teams-button-in-microsoft.html

     

    hope this helps..


    MayankP
    My Blog
    Follow Me on Twitter
    Monday, December 6, 2010 10:07 PM
    Answerer
  • Ok, now I understand what you mean by 'site' :).

    First of all, I would suggest you take a look at eventlogs (from CRM server and SQL Server). This may point you to additional information so as to understand the cause and solve the problem.

    Then I strongly recommend you update to latest rollup (at this moment, rollup 14).

    If problem persists, I would give CRMDiagTool 4 a try. This could be very useful in case you are still having the problem.

    If yet the problem is still there, I would download Bulk Delete tool. Despite this tool is thought for bulk delete scenarios, I think you can use it for deleting only one record.

    I honestly think (and hope) that at this point you've already solved the problem. If not, I would follow MayakanP's suggestions.

    Hope this help, please keep us posted.

    PP


    Microsoft MVP Dynamics CRM | My Twitter: http://twitter.com/pabloperalta | My blog: http://weblogs.asp.net/pabloperalta
    Tuesday, December 7, 2010 1:35 AM