locked
PP3 - Permission error in Media Center while Archiving RRS feed

  • Question

  • Had a problem with getting TV archiving to work with PP3 in Media Center:

    Here is what I have\did:
     - WIndows 7 on my desktop doing the recordings
     - Windows Home Server with PP3 installed
     - Installed new console after WHS was updated on Windows 7 machine
     - Went into Media Center and also installed new add-in and rebooted

    Went and selected 1 TV show to attempt an archive with compression copy for windows mobile device.  Heres my settings:
     - Archived all recordings automatically not checked
     - Checked Move recordings to my home server
     - Checked Create a compressed copy for:  "Windows Mobile"
     - For Save compressed copy to: I selected "Home Server videos folder"

    After it seemed to completed I got the following activities logs: "TV Archive does not have permission to access this folder'
    It is continuing to attempt to archive the recording.  The compression attempt did work and I found the file within my video share on the home server...

    Any help here?

    Also what folder\share would it archive my tv recordings too?  I already had a "TV Recordings" folder created if that matters...

    Dugas...

    Wednesday, November 25, 2009 5:49 AM

All replies

  • Update with more testing: 

    Also tried to remove the compression settings and just performed the archive...  Got the same error: "TV Archive does not have permission to access this folder'.

    I also tried an old vista recording and a newer window 7 recording with no success...

    Any help would be appreciated...

    Wednesday, November 25, 2009 6:58 AM
  • Sounds like something to do with permissions between the media center machine and WHS. Is the default user-id on your media center defined in WHS? Can you browse all your WHS folders from your media center machine (not by remoting in but directly through windows explorer)? If you can browse the folders, then there is a different problem. If you cannot browse the folders you will need to set/adjust your permissions on the WHS and make sure the media center user is defined there.
    Wednesday, November 25, 2009 4:52 PM
  • I know my personal account is there as I can read\write to the shared folders off the WHS.  What account is added by MC?  I will need to look into this.  If the account is not there (I guessing that this is added when I install the MC Add-in) if I uninstall the add-in and reinstall might this fix this issue?

    Thanks...

    Wednesday, November 25, 2009 8:07 PM
  • I was able to fix the same problem for my box.

    While the connector software is installed on the client, the home-server creates a new user for that particular client. It seems, that these user credentials are used, wenn Windows Media Center connects to the Home Server. By default the permissions for Music, Video and Picture folders are set properly. For the TV Archive no permissions where granted.

    To fix this issue I connected to my home server via remote desktop (not the console!). Then I added my computer-named account to the roles for accessing the TV archive folder (in my case the role was named RW_L ... I think!?). Further i started the computer management mmc console to manage my shares. I assign missing permission to my computer-named account and verify that the security settings are set properly. After that I disconnect all users from the tv archive share and restartet the TV archiving service on the client.

    From now on everything is working like expected.
    Monday, November 30, 2009 7:45 AM
  • I was able to fix the same problem for my box.

    While the connector software is installed on the client, the home-server creates a new user for that particular client. It seems, that these user credentials are used, wenn Windows Media Center connects to the Home Server. By default the permissions for Music, Video and Picture folders are set properly. For the TV Archive no permissions where granted.

    To fix this issue I connected to my home server via remote desktop (not the console!). Then I added my computer-named account to the roles for accessing the TV archive folder (in my case the role was named RW_L ... I think!?). Further i started the computer management mmc console to manage my shares. I assign missing permission to my computer-named account and verify that the security settings are set properly. After that I disconnect all users from the tv archive share and restartet the TV archiving service on the client.

    From now on everything is working like expected.
    What folder is the TV Archive? Recorded TV? Looking at the permissions on this share, my computer-named account is not missing and has full access...

    I am getting the same permission error in the activity log on my Windows 7 Media Center and Home Server...

    The user on the mediacenter  box is properly configured as a user on Home Server and has full access to Recorded TV as stated above.

    How do I resolve this permission issue?


    Sunday, December 6, 2009 3:25 AM
  • "Recorded TV" is the right folder. It seems that Windows Media Center uses a special user account to access these folders on the home server. This user account is named like your windows media center box. The problem is, that you won't see this special user in the Home Server console. Therefore you have to login directly on the box via Remote Desktop. There you'll find the standard windows MMC-Console to manipulate the user and role settings.
    Sunday, December 6, 2009 9:52 AM
  • "Recorded TV" is the right folder. It seems that Windows Media Center uses a special user account to access these folders on the home server. This user account is named like your windows media center box. The problem is, that you won't see this special user in the Home Server console. Therefore you have to login directly on the box via Remote Desktop. There you'll find the standard windows MMC-Console to manipulate the user and role settings.
    Special user account? 

    ??

    Like I said, the Recorded TV share has full control for MediaCenter (SERVER\TVBOX) (user account name on both the Media Center box and setup in WHS as a user )

    The group of RW_J which has the description of Read/Write access to RecordedTV has TVBOX as a member


    Sunday, December 6, 2009 5:25 PM
  • I have a german whs box, maybe there are different group and user namings. In my case i have several Win 7 machines. One, for example, is named MCE. Therefore WHS creates a special user named Mc-MCE (during installation of the connector software). This user is used to connect to WHS from the Media Center.

    If you open the computer management console on the WHS. There is an area for Shared Folders. When I look at my shares there is a share "TV-Aufzeichnungen", which should be "Recorded TV" in your case. Right click on this share an open the properties. On the permission page you should add the Media Center computer user and grant full permissions. In the security tab, add the roles with granted permissions to the "Recorded TV" folder. In my case the Role is called RW_L.

    Next you have to disconnect the current Sessions in the computer management console an everything should work as expected from Windows 7 side.

    Monday, December 7, 2009 6:11 AM
  • I'm having exactly the same problem and am unable to resolve it.

    I've logged into my WHS via remote desktop. Then I've gone to:

    Start > All Programs > Administrative Tools > Computer Management > Systems Tools > Local Users and Groups > Groups

    In 'Groups' I can see a group name of RW_X with the description "Members of this group have ReadWrite access to share Recorded TV" If I double-click on this group I see all the members (all my 'normal' WHS users), plus the 'special' member "Mc-HTPCW7".

    So in other words.... everything appears to check out, and yet I still get this error message "Tv Archive Does Not Have Permission To Access This Folder".

    Running out of ideas! Can anyone throw me a bone here? :-)


    Saturday, December 12, 2009 2:37 AM
  • Please have a look at the "Shared\Folders" tool in the computer management console. Under "Shares" you'll find the "Recorded TV Share". Right click this share to open its properties. Select the second permission tab and verify, that your "Mc- users" have alle needed permissions for this folder.
    Sunday, December 13, 2009 9:00 AM