locked
Communicator 2007 GP installation RRS feed

  • Question

  • Well... the server side, it was installed very smoothly, no errors what so ever I had on it

     

    thought the client side, hmm... I have an issue with it, I'm trying to push it to users via Group Policy, here is the error:

     

    Event Type: Error
    Event Source: MsiInstaller
    Event Category: None
    Event ID: 1013
    Date:  4/1/2007
    Time:  10:43:01 AM
    User:  ESENSESOFTWARE\tester
    Computer: NOOR-VM
    Description:
    Product: Microsoft Office Communicator 2007 Public Beta -- 1: ALLUSERS property is not 1 - this MSM cannot be used for a per-user or fallback-to-per-user install 2: 

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 7b 41 34 30 42 30 39 32   {A40B092
    0008: 43 2d 35 33 38 39 2d 34   C-5389-4
    0010: 36 38 34 2d 38 38 36 36   684-8866
    0018: 2d 39 41 42 37 44 46 41   -9AB7DFA
    0020: 46 44 36 32 32 7d         FD622} 


     

    so, I'm... help? anyone? what can I do in here?
    Sunday, April 1, 2007 8:51 AM

Answers

  • Well, I used the steps mentioned in article KB816102, but doing so resulted the error I posted

     

    I tried modifying the .msi packege by editing it, and changing the value of ALLUSERS to 1, I failed

     

    your solution though, worked perfectly, by writing a logon script to deploy the .msi packer, and publishing it through active directory, users were able to have the software installed on their machines upon their logon

     

    the script only has one line:

     

    \\sharename\application.msi /qn /norestart

     

    thanks man, that was really helpful Smile

    Sunday, April 8, 2007 7:15 AM

All replies

  • What exactly are you trying to do and what have you done thus far?
    Monday, April 2, 2007 8:55 PM
  • Hmm...

     

    - Installed LCS 2007 on a Server, it worked

    - Want to push the LC Client to users so they can logon to the server, used Group Policy to do so

    - Client is not installed on computers, publishing or assigning the softawre to either computers or users will result the above error during the installation process

     

    what do I want? I want to install the "Office Communicator 2007" for my users to use, I know it's still on beta, but there has to be a way to install it for all my users without asking them to do it by them selfs
    Tuesday, April 3, 2007 8:51 AM
  • So how are you doing it now that giving you this error?  You mentioned that you aretrying to this group policy, how so?  I distribute software through group policy all the time so I am just curious to know how you are doing it thats making it fail.

     

    The way I do it is by making sure the install files are located in a global directory such as the Netlogon share of the domain.  Next I create a script referring to the msi file that we are trying to install.  Here is an example:

     

    install.bat

    ===============

    \\yourdomain.com\netlogon\communicator.msi /qn /norestart

    ===============

    End

     

     

    With this script created you would add it to the Startup Script portion of the Computer Configuration\Windows Settings\Scripts of your gp.  Doing so will allow each computers local systems account the administrative rights to install this package at the next reboot with no user interaction.

     

     

    Wednesday, April 4, 2007 6:59 PM
  • Well, I used the steps mentioned in article KB816102, but doing so resulted the error I posted

     

    I tried modifying the .msi packege by editing it, and changing the value of ALLUSERS to 1, I failed

     

    your solution though, worked perfectly, by writing a logon script to deploy the .msi packer, and publishing it through active directory, users were able to have the software installed on their machines upon their logon

     

    the script only has one line:

     

    \\sharename\application.msi /qn /norestart

     

    thanks man, that was really helpful Smile

    Sunday, April 8, 2007 7:15 AM