locked
CRM 2013-header tiles show the read only lock icon RRS feed

  • Question

  • Hi,

    Does anybody know how I can get rid of the lock icon that appears next to the field value in the header tiles? the fields like the telephone numbers are not read only but when I put them in the contacts form header (the information form) it shows them like a read only field. however if I put them on the contact form of the contact entity the tile is fine(but still needs to be re-sized which is my next problem). please see the attached screenshot from the information form of the contacts entity

    header tiles in the information form of the contacts

    and  the contact form of the contacts entity

    Friday, December 27, 2013 11:52 PM

Answers

  • I don't know what happened but I only restarted the IIS and when I went back to the form customization, I was able to unckeck the readonly checkbox in the header section (1st screenshot) and then as you can see in the second screenshot I can edit the values in the header tile. (I have changed the control.css to change the tile font and size but it's not relevant to this post)

    screenshot 1 from the customization form.

    Screenshot 2 from my page

     

    • Marked as answer by Edwin Abdalian Monday, December 30, 2013 8:59 PM
    Monday, December 30, 2013 8:59 PM

All replies

  • Hi,

    Please open the Header properties in Contact Form editor.

    Header properties

    Above highlighted things explains -

    1. Field label width only accepts values from 50 to 250. But the header fields and textbox size doesn't seem to adhere to this. The entire header size is divided equally among all the fields kept in the header part of the Form.

    2. All the items in the Header section are read-only by default. Further these fields have Locked on the Form as TRUE and Read Only is TRUE

    Please vote this post as helpful if it helps.


    Ajay Chawla

    • Proposed as answer by Jan AS Saturday, December 28, 2013 10:19 AM
    • Unproposed as answer by Edwin Abdalian Monday, December 30, 2013 3:20 AM
    Saturday, December 28, 2013 6:24 AM
  • Hi Ajay, Thanks for the reply but this doesn't solve my issue.

    I would like to see the phone number into the header tiles, but as you can see in the first picture it doesn't fit and there is no way to do that. even if I increase the width to 250.

    also your second statement is not right. please take a look at my second image. the primary contact phone number is in the tile and you can click on it and edit it. it's not read only.

    Monday, December 30, 2013 3:20 AM
  • I don't know what happened but I only restarted the IIS and when I went back to the form customization, I was able to unckeck the readonly checkbox in the header section (1st screenshot) and then as you can see in the second screenshot I can edit the values in the header tile. (I have changed the control.css to change the tile font and size but it's not relevant to this post)

    screenshot 1 from the customization form.

    Screenshot 2 from my page

     

    • Marked as answer by Edwin Abdalian Monday, December 30, 2013 8:59 PM
    Monday, December 30, 2013 8:59 PM
  • Hi. I also ran into an issue with this. I could not unlock the fields because the check box for "Field is read-only" was greyed out.

    The solution was to open the "customize form" via the standard solution in stead of my custom solution. Also, the problem came back after a while. Then I changed the security role for the users so that they had the rights "Write", "Append" and "Append to" on the field lookup type (in my case Territory)

    Weird buggy behavior, but if anyone else runs into this isse, they might try this solution which helped me

    Pål A


    • Edited by Pål A Friday, September 12, 2014 7:59 AM
    • Proposed as answer by Greg Kawinski Wednesday, November 5, 2014 4:33 PM
    • Unproposed as answer by Greg Kawinski Wednesday, November 5, 2014 4:33 PM
    • Proposed as answer by Kyle Andersen Friday, February 13, 2015 3:32 AM
    Friday, September 12, 2014 7:47 AM
  • I found a nice workaround.  On the field properties window, press F12 to open a debugger.  Select the checkbox next to 'Field is Read-Only'.  Remove the 'disabled' attribute.  Now uncheck the box and click ok.  Save and publish.  

    • Proposed as answer by Greg Kawinski Wednesday, November 5, 2014 4:37 PM
    Wednesday, November 5, 2014 4:37 PM
  • To expand upon this, I normally navigate to the Form editor by way of navigation to the entity itself in CRM (and could not edit the Read Only boolean in the headers). After reading this I navigated to the 'Customize the System' location, found the same form, and was able to edit it freely.

    Friday, February 13, 2015 3:23 AM