locked
Re: Data Analysis View RRS feed

  • Question

  • I am trying to give access to my Manager to view the Data analysis cube in UAT enviornment, The role/rights she has is that of a PM. When she tries to open the link it says access denied.

     

    Has this got to do something with the settings or with the Role assigned to her, Do i have to give her admin rights for her to be able to see?

    Mannnu.

    Thursday, August 11, 2011 3:10 PM

Answers

  • Hi John

    It has been long since this thread has been posted or updated, closing this thread assuming this has been already resolved, closing is necessary in order to keep the forum moderated

    please feel free to either reopen this thread or create a new one if you feel it has not been resolved & warrants further discussion

    Also would suggest if you have found an answer or a workaround to this problem, please share in order for other to get benefit of your experience


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com

    • Marked as answer by epmXperts Thursday, January 31, 2013 2:39 AM
    Thursday, January 31, 2013 2:39 AM

All replies

  • Hi Mannnu,

    Does the Project Server security group that the user is part of have the "View OLAP Data" permission allowed? What version of Project Server are you using?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Thursday, August 11, 2011 3:14 PM
  • Thanks Paul for your reply. As per your suggestions i gave the 'VIEW OLAP DATA" permission to my manager but it still doesnt workk. I am using PWA 2007. The manager can see the cube in Prod though?

    Please help me with any other suggestions on your mind.

     

    Mannu

    Thursday, August 11, 2011 6:04 PM
  • Hi Mannu,

    Have you built the cube since allowing that permission then retest?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Thursday, August 11, 2011 6:05 PM
  • Yes, I have Built the cube.

    I want the others to see it, but dont want to assign admin rights to them.

    Mannu

    Thursday, August 11, 2011 6:15 PM
  • Have you given access to the Data Analysis views in the category that the user has access to? Open the category/s that the Project server group uses and scroll to the bottom to the views and check that the data analysis views are allowed.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Thursday, August 11, 2011 6:19 PM
  • Mannu

    You can  use View effective rights tool to identify security issue

    http://technet.microsoft.com/en-us/library/cc197528(office.12).aspx

    Thanks

     

     

     

    Thursday, August 11, 2011 6:58 PM
  • I tried doing that as well, doesnt work :(  I will try and check if thats the issue with some other user as well.

     

    Mannu

    Thursday, August 11, 2011 7:27 PM
  • Hi Mannu,

    Is the user accessing both Prod and UAT on the same client machine? Are both URLs (Prod and UAT) in the IE trusted site zone for this user?

    thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Thursday, August 11, 2011 8:03 PM
  • The cube role security in OLAP is not being updated correctly, Try to manually add the user to the Role in Analysis server using SQL Management console

    We discovered the security settings for OLAP Views in the Analysis server do not replicate correctly, when claims based authentication is used. The claims prefix on users accounts is not processed correctly.

    We  added user accounts manually to analysis server roles, and then determined that the update cleared the roles. We have implemented Server Side Event handlers to capture role assignments before cube is refreshed, and then put them back in after update is completed

     


    John Purvis Digital Concepts, Inc. Assigned to CSC ECSS Program

     


    Friday, August 12, 2011 4:05 PM
  • Hi John

    It has been long since this thread has been posted or updated, closing this thread assuming this has been already resolved, closing is necessary in order to keep the forum moderated

    please feel free to either reopen this thread or create a new one if you feel it has not been resolved & warrants further discussion

    Also would suggest if you have found an answer or a workaround to this problem, please share in order for other to get benefit of your experience


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com

    • Marked as answer by epmXperts Thursday, January 31, 2013 2:39 AM
    Thursday, January 31, 2013 2:39 AM