none
MPI debugger settings for VS 2008 RRS feed

  • Question

  • I would be very grateful to you for any help with MPI debugger settings.

    This is the story:

     

    1) I have a VS 2008 project set for an MPI executable like this:


    MpiRun Command: mpiexec

    MpiRun Arguments:  -job 64.0 -hosts 3 AUSYDTSS011 3
    Appp command: C:\TFS\RAV2\RAP\Prototypes\HPC\RADA\RECA Prototype\MpiSingleTaskletRun\bin\Debug\MpiSingleTaskletRun.exe
    MPIShim loc: mpishim.exe

     

    (the rest as per MS recommendations)

    2) This is how I have submitted a job for scheduler:

     

    C:\>job submit /numprocessors:3 /requestednodes:AUSYDTSS011 /runtime:00:06:00 /rununtilcanceled:true /scheduler:AUSYDTSS010

    Job has been submitted. ID: 64.

     

    C:\>job view /scheduler:AUSYDTSS010 64

    Id                              : 64

    State                           : Running

    Name                            :

    Project Name                    :

    Owner                           : TSSLAB\aronovv

    Template                        : Default

    Priority                        : Normal

    Resource Request                : 3-3 cores

    Type                            : Batch

    Node Groups                     :

    Requested Nodes                 : AUSYDTSS011

    Allocated Nodes                 : AUSYDTSS011

    Current Allocation              : 3 cores

    Submit Time                     : 10/03/2009 11:12:53 AM

    Start Time                      : 10/03/2009 11:12:53 AM

    End Time                        :

    Elapsed Time                    : 00:00:51:57

    Wait Time                       : 00:00:00:00

    Run As                          : TSSLAB\aronovv

    Pending Reason                  :

    Error Message                   :

    Task Count                      : 0

        Configuring tasks           : 0

        Queued tasks                : 0

        Running tasks               : 0

        Finished tasks              : 0

        Failed tasks                : 0

        Canceled tasks              : 0

     

    3) Nevertheless I got the following when I have started debugging from the head node of the cluster (AYSYDTSS010):

     

    Aborting: Access denied by node 'AUSYDTSS011'.

    mpiexec is attempting to use this node which was not allocated to job '64.0' by

    the Microsoft HPC Scheduler.Press any key to continue . . .

     

    4) When I removed -job clause from the project settings and set CCP_TASKCONTEXT=64.0:

     

    C:\Users\aronovv>set CCP_TASKCONTEXT

    CCP_TASKCONTEXT=64.0

     

    it was even worse:

     

    Aborting: Access denied by node 'AUSYDTSS011'.

    This node is a resource managed by the Microsoft HPC Scheduler and mpiexec was attempting to use it without a scheduled job.Press any key to continue . . .

     

    What would you suggest?

     

    Regards and many thanks,

     

    Valery

     

    BTW: Another problem - my attempt to set a shared resource for 'Application Command' and 'Working Directory' was rejected: CMD does not support UNC names. Many MS examples on-line have UNC settings there. How to fix it? V.

     

     

    Tuesday, March 10, 2009 2:27 AM

Answers