locked
Money Sunset Edition suddenly stopped working on Win 8.1 and Vista RRS feed

  • Question

  • A few weeks ago MS Money Sunset edition (v17.0.120.3817) suddenly stopped working on my main laptop running Win 8.1. When trying to open the Money file, the application crashes. Same problem when trying to restore from a backup Money file. Tried reinstalling Money but no change.

    I then tried using my previous laptop running Vista, which also used to run Money without any trouble, but that didn't help either. Money will start but won't open the Money file (it just hangs). When I trying to restore a Money backup file, I get an error message saying it's corrupted and can't be read.

    I've tried using several Money and Money backup files from several recent system backup iterations, but again no luck.

    I'm running out of ideas at this point and starting to panic since 15+ years of financial data are at stake... :(

    Has anybody encountered this issue, and how to solve it?

    Thanks!

    Leonard.

    Sunday, April 3, 2016 2:40 PM

All replies

  • Note after installing Money Sunset, re-do the patch described in the first sticky post in this forum.

    I would try making a repaired version of your file with File->RepairMoneyFile->StandardFileRepair level 2

    If Money does not open to let you get that far, try opening Sample.mny from your Money install folder 

    If it still does not work, try restoring a backup that pre-dates the problem. So you may need to use your second- or third-newest backup.

     
    Sunday, April 3, 2016 5:58 PM
    Moderator
  • Thanks, Cal.

    I've tried all that:

    1) reinstalled Money Sunset + applied patch

    2) tried to repair file: Money crashed

    3) tried to open Sample.mny file: Money hung/crashed

    4) tried to restore earlier backup, even several months old version: Money crashed

    Not sure what to try next... Even my old laptop running Vista isn't able to open the various Money and backup files I've tried.

    Any more ideas?

    Much appreciate your advice!

    Monday, April 4, 2016 10:52 PM
  • You have done the right things it seems to me. That is unusual that reinstalling Money and opening Sample.mny does not work.

    Try opening Money by right-clicking the launch icon and choosing Run As Administrator. That is easy, but I have limited hope for that one. Still, it is worth a try.

    The next thing, which is more work, is to create a new user profile.

    http://windows.microsoft.com/en-us/windows/fix-corrupted-user-profile#1TC=windows-7 is Windows 7 oriented, but I think the process is similar in Vista and Windows 8.

    Here is another write-up: https://neosmart.net/wiki/corrupt-user-profile/

    I would just create the account to see if you could then run Sample.mny from that account. If that worked, you could consider whether you wanted to move your stuff to the new profile or not.
    Tuesday, April 5, 2016 2:05 AM
    Moderator
  • Hi Cal,

    Thanks again for taking the time to help with this.

    I've made a bit of progress: Money on my Vista machine will open Sample.mny with no problems.

    However, when I try to open my own Money file, the following happens:

    1) I'm prompted to enter the password (and click <Sign In>)

    2) I get the error message: "The e-mail address or password is incorrect. Please try again.  If you are sure that you typed your credentials correctly, the server may be undergoing maintenance. <Check Server Status>[link]. Please try again later, or if you are opening an existing file, sign in without access to all online services."

    The password I entered was correct (if I use an incorrect password, the error message looks a bit different: "The password you entered was incorrect. Please try again.")

    When I try to restore a backup version of my own Money file, the following happens:

    1) I'm prompted to name the restored file

    2) I'm prompted to enter the password

    3) I briefly see some progress bars flickering

    4) I get the error message: "'<destination filename>' is corrupted or is not a Money data file. Money has tried to repair this file but failed. You will need to open your most recent backup file to access your data."

    I really wonder what's going on here. It almost feels as though it's the wrong version of Money, due to the reference to server problems. I'm not given the option to sign in without access to online services.

    Alternatively, could it be some sort of password issue? I always kept the same password containing a mix of letters, numbers and special characters...

    Does any of the above behavior make sense to you?

    I appreciate your thoughts!

    In the meantime, I'll try the new user profile idea.

    Leonard

    Tuesday, April 5, 2016 10:54 PM
  • Have you tried restoring your second or third newest backup. When you try a restore, browse to your Documents folder and pick a new filename. That way you will not overwrite your *.mny file, that might be usable or repairable after things are otherwise working.

    Try disconnecting from the Internet and then opening Money.

    Wednesday, April 6, 2016 12:10 AM
    Moderator