locked
IFD & local access RRS feed

  • Question

  • Hi,

    Have CRM running IFD on 2008.

    IFD is working correctly from outside the server.  From the server itself I am unable to log in to MS CRM. I've tried through IP address, localhost, hostname and the FQDN used from outside the network.

    Everything is installed on the server itself (SQL, SRS).

    Currently I have Anonymous auth enabled (Required for external IFD) , Forms and Windows enabled.

    The primary issue is that I am unable to run a bulk insert job which I believe is down to the fact that the service can't authenticate locally.

    I would particularly like to know the correct setup with regard to authentication in IIS for IFD.

    Thanks in advance,


    Karlo
    Karlo Swart - http://www.ver206.com
    Friday, February 13, 2009 10:44 PM

Answers

  • Hotfix did not resolve the issue.

    Found a resolution at

    http://kbalertz.com/953643/Error-message-access-Microsoft-Dynamics-server-running-Windows-Server-Address-different-address-family-network.aspx

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tcpip6\Parameters
    3. Right-click Parameters, point to New, and then click DWORD Value.
    4. Name the registry entry that you created in step 3 to DisabledComponents.
    5. Double-click DisabledComponents.
    6. In the Edit DWORD Value dialog box, click Hexadecimal in the Base area.
    7. In the Value data box, type 20.

      Note By default, the value in the Value data box is zero.
    8. Click OK.
    9. On the File menu, click Exit.
    10. Restart the Microsoft Dynamics CRM 4.0 server.
    HiH




    Karlo Swart - http://www.ver206.com
    • Marked as answer by Karlo Swart Sunday, February 15, 2009 10:22 AM
    Sunday, February 15, 2009 10:21 AM

All replies

  • Update to my previous problem:

    I believe the client has installed the hotfix for this, however when I try to browse to the SDK URL, I receive the following error:

    Request IP Address has different address family from network address.

    Any ideas?

    Karlo Swart - http://www.ver206.com
    Saturday, February 14, 2009 11:51 AM
  • Hotfix did not resolve the issue.

    Found a resolution at

    http://kbalertz.com/953643/Error-message-access-Microsoft-Dynamics-server-running-Windows-Server-Address-different-address-family-network.aspx

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tcpip6\Parameters
    3. Right-click Parameters, point to New, and then click DWORD Value.
    4. Name the registry entry that you created in step 3 to DisabledComponents.
    5. Double-click DisabledComponents.
    6. In the Edit DWORD Value dialog box, click Hexadecimal in the Base area.
    7. In the Value data box, type 20.

      Note By default, the value in the Value data box is zero.
    8. Click OK.
    9. On the File menu, click Exit.
    10. Restart the Microsoft Dynamics CRM 4.0 server.
    HiH




    Karlo Swart - http://www.ver206.com
    • Marked as answer by Karlo Swart Sunday, February 15, 2009 10:22 AM
    Sunday, February 15, 2009 10:21 AM