locked
sql server connectivity RRS feed

  • Question

  • when installing the OCS server into the pool, I get:

     

    "Unable to retrieve the WMI setting of MSFT_SIPLogSetting from pool backend '<name>'.  (Error code: 0x800407d0"

     

    As i supply Gest access account username and password.

     

    I have a few questions about this.

    Who should own the SQL database instance, previously in LCS i had a service account own it, but this install is different and you are not asked credentials when installing a pool or a server into a pool.  Should I have the Domain Admin account that is installing the server own the DB as well?

     

    Also, concidering that this might be a config issue on the pool, i ran through config again.  As this is a small environment, i do not have a hardware load balancer, what do I set for the SNAT or DNAT option in configure enterprise pool option?

     

    I have been looking through docs and I haven't found anything.

     

    Last, are there any groups other than RTCUniversalServerAdmins that I should add the Domain Admin account that is installing OCS to so that I can make the install run smoothly?

     

    Thanks for the help.

    Tuesday, June 12, 2007 7:40 PM

Answers

All replies

  • I am also having the same problem. Anyone have any clue?
    Tuesday, June 19, 2007 7:19 PM
  • Hi,

     

    I'm still new to OCS 2007, but I have just installed it without problems using a back-end SQL server.

     

    I am using SQL 2005 EE with SP1. I am using an account that is a member of Enterprise Admins and this account was granted DBO permissions on the SQL server (I'm assuming its operating in AD integrated authentication mode). We are only using the default instance.

     

    I then installed the SQL 2005 client tools on the OCS front-end server and applied SP1 so it matched the server version. When I ran the Create Enterprise Pool step, I only entered the SQL server name in the SQL Server instance field, during the wizard, as the default instance was used (ie. I just entered SERVERNAME, not SERVERNAME\INSTANCE as suggested).

     

    That's all I did and it worked.

     

    Hope this helps.

     

    Rgds,

     

    Morris Newman

    Wednesday, June 20, 2007 1:08 AM
  • That would work possibly, but we are using named instances, as this SQL server houses the LCS 2005 database as well, on the default instance.  So we need to build a new instance and name the OCS instance.

     

    With default instances, you still have to have someone take ownership of the isntance, the the first question is still unanswered.  What did people put in as the owner of the database etc.

     

     

    Wednesday, June 20, 2007 3:18 PM
  • Hello,

    The SQL Server 2005 Service account is usually an account that was designated during the installation of SQL Server 200x. It should be a specific service / user account that was assigned during the installation of the SQL Server. The service / user account should have the domain / local policy / user rights / log on as a service applied to it. The domain admins group has this right assigned inherently.

    SQL Server 2005 will use Windows authentication inherently. So when installed into a domain the local built in administrators group will be added to the SQL Server 2005 sysadmin role allowing members of this group full access to the SQL Server config and databases. The default members of this group are the local administrator and the domain admins group. Also, the RTCUniversalServerAdmins group will be added to the built in Administrators group on the SQL Server with the creation / activation of the pool.

    SNAT is the default choice. Should you ever decide to configure a LB  for use with a expanded topology you will want to use SNAT. Here is some more info

    It is recommended that you configure your load balancer to operate in SNAT mode if you can. If the load balancer for this pool is configured to operate in DNAT mode, connections from member servers in the pool will be redirected to the local host. Redirecting connections to the local host is necessary so that the pool can operate in DNAT mode, but it can negatively affect the availability of the pool. To ensure maximum availability of the pool, you should configure the load balancer to operate in SNAT mode.

    To install and activate the the OCS 2007 EE Servers you will need to be a member of the RTCUniversalServerAdmins and the Domain Admins group

    Thanks,

    Mike Adkins
    Tuesday, July 3, 2007 2:13 PM
  • Update:

    Same problem, new servers.

     

     

    I brought up a new SQL server and a new server for OCS 2007.

    Installed the pool on named instance, using a service account wiht domain admin, local admin, RTCUniversal Server admin, log on as service privlidges.

     

    I logged on as that service account from here on out on both SQL and on OCS servers to do configs and installs.

     

    I created the DNS entry for the FQDN pool name to point to the SQL server.

     

    I did the configuration of the pool.

     

    I logged on to the OCS server as the service account and tried to add the server to the new pool, and after going through the setup pages for creating access accounts and when I hit next on the RTCguest account i get the error

     

    "Unable to retrieve the WMI setting of MSFT_SIPLogSetting from pool backend '<name>'.  (Error code: 0x800407d0"

     

    The install then terminates.

    Any suggestions on why this WMI error is happening?

     

    Friday, August 3, 2007 5:02 PM
  • http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1867609&SiteID=57

     

     

    answered.  but is there any clue on why these services are needed but not started?

     

    Should these services stay started?  are all needed?

     

    Can someone shed some light?

    Friday, August 3, 2007 5:14 PM