none
Launching an MPI task returns error number 10061 RRS feed

  • Question

  • Hi! I'm trying to use a LAMMPS prebuilt executable on my windows machine, using parallel libraries through OpenMP, I tried many ways to call the mpiexec, to no avail, I always get the same error, which says :

    ERROR:Error while connecting to host, No connection could be made because the target machine actively refused it. (10061)

    I tried asking it to give me debug information and allowing both mpiexec.exe and smpd.exe in the windows firewall, but it didn't change a thing.

    If that can help, I am running this on my own machine, on which I'm the administrator in an administration command window, system runs on Win10 with an AMD Ryzen 1700X processor.

    I put the entire output as well as my call to mpiexec in this pastebin : https://pastebin.com/aPebwPxg

    Any help would be greatly appreciated! If you need any more detail don't hesitate, I'll answer as fast as I can!

    Thanks a lot!

    Antoine.


    Friday, June 14, 2019 7:18 PM

All replies

  • Hello Antoine,

    Can you please make sure that msmpi is functional by running something like

    mpiexec -n 2 hostname

    -thanks, Anna

    Wednesday, June 19, 2019 6:49 PM
  • Hi! Sorry for the delay, when I run mpiexec -n 2 hostname I get the following output :

    Desktop
    Desktop

    I'm guessing it means it's running properly?

    Thanks again!

    Friday, June 21, 2019 5:59 PM
  • Yes, it means that msmpi itself is running OK. You may want to try and add the LAMMPS executable to the list of firewall exceptions as well. Also, was the executable built against the same version of msmpi that is running on your machine? It is usually OK to run older msmpi code with newer runtime, but the opposite is not always possible.
    Monday, June 24, 2019 6:00 PM
  • I honestly don't know about wether or not it was built for that version, all I know is that it's the 12th of december 2018 version, which should in theory be stable from my understanding! What should I do to try it out?

    Thanks again!

    Tuesday, June 25, 2019 12:06 PM
  • According to this http://packages.lammps.org/windows.html LAMMPS is supposed to work with MPICH, not MSMPI.
    Wednesday, July 3, 2019 11:07 PM
  • Oh I thought any MPI application should work as I was previously running it on an mpiexec from intel parallel studio XE, but it would make sense if it does just support MPICH! I tried using it previously but unsuccessfully, I'll retry and post and update if it did the trick! Thanks :)
    Friday, July 5, 2019 12:20 PM