locked
WHS 2011 TS Gateway not working RRS feed

  • Question

  • Hi,

    Whenever I try to connect to a computer over the internet I get the following error message:
    Your computer can't connect to the remote computer because the Remote Desktop Gateway server is temporarily unavailable. Try reconnecting later or contact your network administrator for assistance.

    Before WHS 2011 I used WHSv1 and a separate Server 2008 R2 as a TS Gateway. Although I couldn't connect to PC's through the WHSv1 website, it worked fine when I entered the correct information in the RDP client manually.

    I understand that WHS 2011 should be configured to use TS Gateway out-of-the-box, but something seems to be wrong. I haven't changed anything in my router, I only replaced WHSv1 with WHS 2011.

    WHS 2011 now uses the IP address that was assigned to WHSv1 before, so I shouldn't have to modify any settings in my router. Note that I have disabled UPNP in my router because I'm a control-freak :). I opened port 80 and 443 which should be enough for TS Gateway since it uses port 443 (if I remember correctly).

    I hope someone can help me figure this out, since I just moved my data to WHS 2011 and don't really want to reinstall...

    Thanks!

    Friday, May 13, 2011 7:31 AM

All replies

  • Manually setting the router forwarding rules for port 80 and 443 should be fine.
    Did you go through the Remote Web Access wizards for setting up "Router" (you can skip the automatic router configuration) and "Domain name"?

    - Theo.


    No home server like Home Server
    Saturday, May 14, 2011 2:23 PM
    Moderator
  • I went through the wizards and setup the router manually, as far as I can see everything should work just fine. The Remote Web Access website is available on the internet and I can login without any problems. The only thing that doesn't work on the Remote Web Access website is connecting to computers.
    Saturday, May 14, 2011 5:56 PM
  • This should work "out of the box" :-|
    I guess the "Remote Gateway Service" is started? No server alerts on the Dashboard?
    You domain is registered and certificate is in place?

    Are you able to start the Dashboard remotely (from Web Access)?
    - Theo.


    No home server like Home Server
    Saturday, May 14, 2011 6:25 PM
    Moderator
  • Hi,

    Although I didn't want to, I ended up reinstalling WHS2011 and moving my data to it.
    Since my server runs on VMWare ESXi it was possible to reinstall while the old installation was running :).

    Now I'm able to login to the Dashboard remotely and other PC's on my network (from Web Access).

    I'm very pleased with this, but I do still have one "issue". Apparently the RD Gateway uses a custom authentication method through Web Access so the user shouldn't have to login twice. This is nice when using Web Access... I really like to uses Royal TS on my PC and Xtralogic RDP Client on Android though, both of which try to use Windows Authentication with the RD Gateway. This fails because the WHS2011 RD Gateway doesn't allow this kind of authentication.

    Now I'm wondering whether it's possible to add support for Windows Authentication to the RD Gateway?

    Wednesday, May 18, 2011 7:00 AM