locked
dynamics CRM 2011 and VS 2012 SDK, cannot deploy to an existing solution (plugin error) RRS feed

  • Question

  • I have to make changes to an existing solution of CRM 2011. Therefore I am using VS 2012 and the CRM 2011 SDK. The VS CRM Package consists of some webresources and 2 plugins. I haven't made any changes to the plugins but it seems they are responsible for the error.

    When I want to deploy the solution via VS 2012 to the existing solution I am getting following error:

    Error registering plugins and/or workflows. An unexpected error occurred. C:\Program Files (x86)\MSBuild\Microsoft\CRM\Microsoft.CrmDeveloperTools.12.targets 176 4

    I've enabled tracing on my Server and in the logfile the following is stated:

    Web Service Plug-in failed in SdkMessageProcessingStepId: {C03B8615-ECD8-DB11-B397-0019B9204DA9}; EntityName: sdkmessageprocessingstep; Stage: 30; MessageName: Create; AssemblyName: Microsoft.Crm.Extensibility.InternalOperationPlugin, Microsoft.Crm.ObjectModel, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35; ClassName: Microsoft.Crm.Extensibility.InternalOperationPlugin; Exception: Unhandled Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Web.Services.Protocols.LogicalMethodInfo.Invoke(Object target, Object[] values) at Microsoft.Crm.Extensibility.InternalOperationPlugin.Execute(IServiceProvider serviceProvider) at Microsoft.Crm.Extensibility.V5PluginProxyStep.ExecuteInternal(PipelineExecutionContext context) at Microsoft.Crm.Extensibility.VersionedPluginProxyStepBase.Execute(PipelineExecutionContext context) Inner Exception: System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.Crm.Platform.SolutionAwareComponents.ComponentStateTransitionFactory.CreateStateTransition(FactoryInput input, ComponentStateTransitionActionFactory actionFactory) at Microsoft.Crm.BusinessEntities.BusinessProcessObject.DoCreate(IBusinessEntity entity, ExecutionContext context)

    I've wasted hours with finding the solution to this problem - but without luck. If I deploy the CRM-Package to a newly created solution it is working.

    Can anyone help with this please?

    Thanks


    edit: I am on rollup 15, but tried it on different rollups as well (11,13,17..) I've also tried it with different machines (CRM Server and Client machines)

    Tuesday, July 22, 2014 4:29 PM