locked
Discrepancy with trasfer speeds - WHS and XP - Gigabit RRS feed

  • Question

  • Whats up,

    I have been scouring the forums lately trying to figure this one out, hopefully someone can chime in on this. First, here are some transfer speeds:

    Windows XP and Windows Home Server (no folder duplication):

    Drive to Drive: Starts at 40MB/Sec and raises to 60MB/Sec idle

    Drive to Share Drive: Starts at 30MB/Sec and drops to 20MB/Sec idle

    Share Drive to Drive: Starts at 40MB/Sec and raises to 60MB/Sec idle

    At first I thought this was a WHS thing, but I can reproduce it on my XP box as well. I can transfer data between normal SATA II drives at 60MB/Sec. When I create a share folder on one of the drives and then map it using the IP address (ip address of PC containing the drives - not remote - loopback using ip) it crawls along at 20MB/Sec. I'm not talking sending from one machine to another, I can reproduce this using one machine isolated from the network. The mapped share is just looping back, it's not on a remote PC.

    But the same applies for network shares, just trying to simplify it - it's not a switch/router/cable/ issue. I can receive from the server at 60MB/Sec, but when I sent files to the server it's at 1/3 the speed.

    You can try this for yourself. Download FastCopy here: http://www.ipmsg.org/tools/fastcopy.html.en

    Transfer a 10GB file or so from DRIVE A to DRIVE B not using any type of sharing and record the rate. Now on DRIVE B make a folder (share_test or whatever) and add sharing with write access. Map the drive using your current ip address (\\192.168.x.xxx\share_test\ or similar using T: for the drive letter). Now try and transfer the 10GB file from DRIVE A to MAPDRIVE T:\ and record the speed. If you’re in the same boat as me there should be a hefty discrepancy.

    So I set up FTP using IIS and gave that a shot. Using this method has mixed results, but it is definitely capable of 60MB+/Sec. If your transferring a few large files than this way would be a god idea. If you’re transferring allot of small files this can actually take much longer than transferring it at 20MB/Sec using explorer because of the pause after each file upload (using FileZilla at least).

    I can receive 10GB at 60MB/Sec in about 3 minutes, transferring at 20MB/Sec it’s around 9 minutes. Using FTP is was around 16-18 minutes because there were allot of small files.

    So what I’m wondering is what is capping the transfers to a share at 20MB/Sec? Even though I can receive from the share at 60MB/Sec. And considering that I can send the file to the drive without using a share at 60MB/Sec.


    It’s definitely not a limitation of the hardware, something else is coming into play if FastCopy and FTP can do it - but what?

    Is there a third party program that doesn’t have this limitation? Is there a way to remove the explorer limitation?


    TIA

    PS: Is it bad to access D:\shares\foldername directly? Or are you only supposed to acced it by using \\servername or \\ipaddress? FTP doesn't seem to like map drives so the only way I can FTP to the shares is to make D:\shares\ the root FTP folder.
    Monday, March 17, 2008 9:24 PM

Answers

  •  bricklayer wrote:


    PS: Is it bad to access D:\shares\foldername directly? Or are you only supposed to acced it by using \\servername or \\ipaddress? FTP doesn't seem to like map drives so the only way I can FTP to the shares is to make D:\shares\ the root FTP folder.

     

    Simple answer - yes!

     

    You should only ever access your shares either through the Shared Folders icon or via \\servername\sharename.

     

    Andrew

    Wednesday, March 19, 2008 4:39 PM
    Moderator
  • Ok, I figures out why I way getting such slow transfer speeds in XP: http://support.microsoft.com/kb/895932

    System Properties -> Advanced -> Performance -> Advanced -> Memory Usage:

    Enable "System cache" instead of "Programs"

    Cruising along at 60MB+/sec both ways now Smile


     Andrew Edney wrote:

     bricklayer wrote:


    PS: Is it bad to access D:\shares\foldername directly? Or are you only supposed to acced it by using \\servername or \\ipaddress? FTP doesn't seem to like map drives so the only way I can FTP to the shares is to make D:\shares\ the root FTP folder.

     

    Simple answer - yes!

     

    You should only ever access your shares either through the Shared Folders icon or via \\servername\sharename.

     

    Andrew



    Ok, good to know. If I where to set up an FTP server would the root folder have to be on a drive that's no part of the pool? Is it possible to have D:\shares the root some other way? So that when I connect with FTP the folder that appears displays Music,  Photos, Public, Videos, etc.

    And a little off topic but does anyone know what these errors mean and how to get rid of them?

    Code Snippet


    cannot copy *filename*: the path is too deep


    and


    The specified network name is no longer available




    Path too deep has nothing to do with character lengh eg ( E:\video\some_video.mpg to \\Server\Videos\ ). I have a file on a seperate drive and everytime I copy it over to the share I get the path too deep error.

    Friday, March 21, 2008 1:40 AM

All replies

  •  bricklayer wrote:


    PS: Is it bad to access D:\shares\foldername directly? Or are you only supposed to acced it by using \\servername or \\ipaddress? FTP doesn't seem to like map drives so the only way I can FTP to the shares is to make D:\shares\ the root FTP folder.

     

    Simple answer - yes!

     

    You should only ever access your shares either through the Shared Folders icon or via \\servername\sharename.

     

    Andrew

    Wednesday, March 19, 2008 4:39 PM
    Moderator
  • Ok, I figures out why I way getting such slow transfer speeds in XP: http://support.microsoft.com/kb/895932

    System Properties -> Advanced -> Performance -> Advanced -> Memory Usage:

    Enable "System cache" instead of "Programs"

    Cruising along at 60MB+/sec both ways now Smile


     Andrew Edney wrote:

     bricklayer wrote:


    PS: Is it bad to access D:\shares\foldername directly? Or are you only supposed to acced it by using \\servername or \\ipaddress? FTP doesn't seem to like map drives so the only way I can FTP to the shares is to make D:\shares\ the root FTP folder.

     

    Simple answer - yes!

     

    You should only ever access your shares either through the Shared Folders icon or via \\servername\sharename.

     

    Andrew



    Ok, good to know. If I where to set up an FTP server would the root folder have to be on a drive that's no part of the pool? Is it possible to have D:\shares the root some other way? So that when I connect with FTP the folder that appears displays Music,  Photos, Public, Videos, etc.

    And a little off topic but does anyone know what these errors mean and how to get rid of them?

    Code Snippet


    cannot copy *filename*: the path is too deep


    and


    The specified network name is no longer available




    Path too deep has nothing to do with character lengh eg ( E:\video\some_video.mpg to \\Server\Videos\ ). I have a file on a seperate drive and everytime I copy it over to the share I get the path too deep error.

    Friday, March 21, 2008 1:40 AM
  •  bricklayer wrote:
    Ok, I figures out why I way getting such slow transfer speeds in XP: http://support.microsoft.com/kb/895932

    System Properties -> Advanced -> Performance -> Advanced -> Memory Usage:

    Enable "System cache" instead of "Programs"

    Cruising along at 60MB+/sec both ways now


     Andrew Edney wrote:

     bricklayer wrote:


    PS: Is it bad to access D:\shares\foldername directly? Or are you only supposed to acced it by using \\servername or \\ipaddress? FTP doesn't seem to like map drives so the only way I can FTP to the shares is to make D:\shares\ the root FTP folder.

     

    Simple answer - yes!

     

    You should only ever access your shares either through the Shared Folders icon or via \\servername\sharename.

     

    Andrew



    Ok, good to know. If I where to set up an FTP server would the root folder have to be on a drive that's no part of the pool? Is it possible to have D:\shares the root some other way? So that when I connect with FTP the folder that appears displays Music,  Photos, Public, Videos, etc.

    And a little off topic but does anyone know what these errors mean and how to get rid of them?

    Code Snippet


    cannot copy *filename*: the path is too deep


    and


    The specified network name is no longer available




    Path too deep has nothing to do with character lengh eg ( E:\video\some_video.mpg to \\Server\Videos\ ). I have a file on a seperate drive and everytime I copy it over to the share I get the path too deep error.

     

    Did you include Windows Home Server in your transfer testing or just Windows XP?  The reason I ask that is because Windows Home Server is already set to the faster performance option by default.

    Friday, March 21, 2008 10:49 PM
    Moderator
  • @Joel Burt

    No, I didn't try Home Server. I was doing all my testing on XP, when I found the fix. I was thinking that Home Server might have it disabled too. But as you stated, it was already on by default. The drives on the server are pretty full compared to the XP drives, so it's around 40-50MB/sec on a full drive (nearing edge of platter).

    Really this just helps transfers between clients and from the server to clients. The client to the server transfers are the same speed. But no matter which way the traffics going, it's going at full speed Smile

    O and this worked magic on the time it takes for a shares to pop-up (works on WHS too): http://www.extremetech.com/article2/0,1697,1722545,00.asp

    It's like a huge local drive Smile
    Saturday, March 22, 2008 1:07 AM