Remote Desktop and Cleartype/Show Window Contents RRS feed

  • General discussion

  • First, my thanks to the Live Mesh team for fixing some of the occasional but vexing problems that plagued some machines such as my own after the early October update. My Remote Desktop access is now working again with Thursday's update.

    There is one feature of Remote Desktop that used to exist prior to early October but no longer exists in the latest update, however. Previously, if I initiated a Remote Desktop session to a machine in which no user was logged in, I'd always get a session in which Cleartype was enabled and in which I'd see the complete contents of a window as I moved it around on the screen. Only when logging into a system in which a user was already logged in and Live Mesh (not just the Remote Desktop service) was therefore running did I experience a lack of Cleartype and only a window outline when moving a window around. Also, copy and paste from remote to local machine only worked in the latter case.

    Now, every case is like the latter case. Even when I log into logged off machines, I don't obtain Cleartype in a remote session and see only a window outline when moving windows around. In other words, the session seems to have been bandwidth-economized.

    I wonder if this was a deliberate choice, a change of default settings, or a combo of both. Is there a way to reenable at least Cleartype, perhaps through a registry setting?

    Sunday, November 2, 2008 3:21 AM

All replies

  • Hey David,

    Thanks for the comments regarding Cleartype becoming disabled in remote sessions.  I've opened a bug to track this issue and see what's going on with it.

    Sunday, November 2, 2008 5:55 AM
  • While investigating, please note that Cleartype as well as seeing windows contents while dragging has *never* worked for me while logged in to Live Mesh even prior to the last couple of update. However, prior to the last update, both of these features *did* work if I remote accessed a system in which all users were logged off such that only the Live Mesh Remote Desktop service was running in the background. At the same time, however, this configuration had also simultaneously resulted in copying and pasting files between remote and local to not function. Two very different behaviors depending on whether or not a user was logged in with the Live Mesh program started and signed on.

    What's changed for me with the latest update is that this latter behavior has disappeared. Now, I never get Cleartype or visible windows contents while dragging and I always have the ability to copy/paste (drag and drop now, actually). This now applies whether or not only the service is running or if my account is logged in and Live Mesh running/signed in.

    I hope I've made clear the difference in behaviors and that this is a clue to what's going on.

    Monday, November 3, 2008 11:06 PM