error when syncing: Cannot insert the value NULL into column 'local_create_peer_timestamp' RRS feed

  • Question

  • I just set up Datasync between SQL Azure(hub) and an On-prem Server (spoke).  The very first sync worked with no errors.  However, the second Sync failed with the error "Cannot insert the value NULL into column 'local_create_peer_timestamp,  the table '[my table name]_dss_tracking'; column does not allow nulls. UPDATE fails.'" for one of the tables.  The table in question has a composite primary key (int, nvarchar(100)).  Also, the only other reference to this error I found involved federations, which we do not have.  Further, now, any time I delete from this table (on the spoke) it throws the same error.  Any help would be greatly appreciated.  -Joe
    Tuesday, March 12, 2013 3:20 PM

All replies

  • can you confirm if the _tracking table has both columns for your composite PK? 
    Wednesday, March 13, 2013 2:00 PM
  • I am having the very same problem after deleting rows in my source table. Is there any solution? - Andreas
    Monday, June 23, 2014 11:10 AM