locked
Data source connection lost? RRS feed

  • Question

  • Hi,

    I'm afraid I lost some Data Connection for my Excel Reports in PWA 2010:

    I'm able to create a new Excel Report and then to publish it to SharePoint 2010, but after that I cannot display it in PWA: "Impossible to open the workbook in the browser".

    I can open it in Excel 2010, but I get a dialog box: "Impossible to generate the SSP1 contexte", and then I cannot refresh the data: the system displays the settings of the expected connection in a dialog: "SQL Server connection" : Server name, Use trusted connection, Connection ID, Database name… everything seems ok, but when I click OK I get the error:

    ·         Connection failure

    ·         SQL Status: 'HY000'

    ·         SQL Server error : 0

    How can I rebuild the data connection?

    Thanks for your help


    Saturday, April 2, 2011 9:39 AM

Answers

  • sorry, didn't specify - you don't need to do that.  you just need to delete your BI Centre site, and then Edit your PWA site from your Service App page.
    http://blogs.umtsa.co.za/nicoo
    • Marked as answer by WLID1966 Sunday, April 3, 2011 12:18 PM
    Sunday, April 3, 2011 12:12 PM

All replies

  • Hmm..interesting one...

    You could recreate the BI Centre, but this will obviously mean you will lose any customizations you have made.  To do this delete the BI Centre, go to your Project Web App Service App properties, and just Edit your PWA site.  this will recreate the PWA site.

    Brian Smith also talks about recreating the site @ http://blogs.msdn.com/b/brismith/archive/2010/08/24/project-server-2010-business-intelligence-center-behind-the-scenes.aspx :

    To delete the BI Center (once you have re-read the paragraph above, and are really, really sure you want to do this), click on the option in the left navigation for Business Intelligence, then Site Actions, Site Settings, Delete this site (and it doesn’t go into the recycle bin!).  Once it is gone then check that your default AAM is pointing where you want it and go to the Project Service Application, select the Edit option from the drop down for the site you wish to re-create your Business Intelligence Center. then without making any changes in the page that comes up - click Edit.


    http://blogs.umtsa.co.za/nicoo
    Saturday, April 2, 2011 8:48 PM
  • Thanks Nico,

    One more question about <<then check that your default AAM is pointing where you want it >>

    How I will do that?

    Thanks again

     

    Sunday, April 3, 2011 9:48 AM
  • sorry, didn't specify - you don't need to do that.  you just need to delete your BI Centre site, and then Edit your PWA site from your Service App page.
    http://blogs.umtsa.co.za/nicoo
    • Marked as answer by WLID1966 Sunday, April 3, 2011 12:18 PM
    Sunday, April 3, 2011 12:12 PM