locked
WHS 2011 Connector 95% rollback install failed redux RRS feed

  • Question

  • Hey all,

    I was reluctant to open yet another thread regarding connector installs that begin to rollback after almost completing at 95% completion, but I have discovered a new twist to my situation.

    For testing purposes I created a new WHS 2011 server in a VM and the troublesome client connector installs with without issue.  Uninstall that and try to connect with my production server and the connector install fails again at 95%.  I have seen a lot of troubleshooting regarding the clients but in my scenario I think something has gone wrong with the server.

    Any thoughts on how to troubleshoot this further?  

     

    James

     

    Tuesday, November 22, 2011 6:14 AM

All replies

  • One possibility comes to mind.

     

    Is it possible that the connector software on the server in question

    is corrupt or missing a module?

    Tuesday, November 22, 2011 6:40 PM
  • Gary,

    Thanks for your help.  In order to test this is it as easy as copying the bin folder from the working VM server?  Not sure what file or files make up the connector software on the server.

     

    James

    Tuesday, November 22, 2011 6:49 PM
  • I think the easyest way to test is by installing the connector software (from the server in question)

    to a different client if possible.

    Tuesday, November 22, 2011 7:06 PM
  • Garry,

    First, apologies for spelling your name wrong in my last reply.

    Just to make sure we are on the same page:

    I have a test client that I have tested with multiple flavors of Win7.  When pointed at my production server all attempts to install the connector fail as described above.

    Same client pointed to my VM test server and all is well.  It does appear that something about the connector on my production server is wrong. 

    I would like to bring the connector files from the working test server to my production server as a next step.

     

    Not sure form your last reply what (exact) steps you would like me to next?

     

    Apologies if I am missing the forest for the trees.

     

    James

     

     

    Tuesday, November 22, 2011 7:34 PM
  • As you stated I'm not sure if copying the bin folder would be inclusive of all the necessary files

    outside of reinstalling. If you don't have any data on the server yet I suppose a reinstall would

    be the best bet.

    Tuesday, November 22, 2011 7:41 PM
  • Garry,

     

    This is a production server with 6 drives and 12TB.   If at all possible I would like to troubleshoot/fix the connector rather than flattening the server and starting over.  

     

    James

    Tuesday, November 22, 2011 8:28 PM
  • I have 3 PC's running Win7 Home Premium.  2 of them are Sony Viao all in one's.  The Connector installed without a hitch on 2 of them, including one of the Sony's, but only installs to 95% on the other Sony, then rolls back.  I've tried turning on and off the Media Center settings, turned off everything that I could and it still won't install.  I don't think the problem is with the Server.  I think these problems are with the compatibility with the Clients.

     

    Lynn


    Lynn M. Lindaman MD
    Wednesday, November 23, 2011 11:15 PM
  • Has anybody found a solution to the above problem? I have spent over 4 hours yesterday, I am having the same problem on my laptop and desktop that  i am trying to connect to whs2011.

    Thanks

    dockuttu

    Thursday, January 5, 2012 1:15 PM
  • Dockuttu-

     

    I have not found a solution yet.  My troubleshooting indicates that it is a server issue.  Are you using any third party drive pooling products on your server?  I ask because in my case I suspect a problem with Stablebit DrivePool. 

     

    James

     

    Thursday, January 5, 2012 5:10 PM
  • Dockuttu-

    I have not found a solution yet.  My troubleshooting indicates that it is a server issue.  Are you using any third party drive pooling products on your server?  I ask because in my case I suspect a problem with Stablebit DrivePool. 

     

    James

     

    James - Glad you mentioned DrivePool. I'm running that as well and have the same probs and can't seem to connect. Unfortunately I've already got 5GB backed up on the pool and really hoping not to have to kill it to hook up the Connector.

     

    Is there a way to uninstall DrivePool without losing all the data?

     

     

    Thursday, January 5, 2012 10:08 PM
  • Thanks James for such a quick reply. I am running stable bit and i was planning to backup my data and uninstall it. I am planning to try drivebender.

    Sometimes I feel that i should just go back to WHS V1. Luckily i didn't disassembled my old server. All this DE issue is too much and adds unnecessary stress.

    Will keep you update.

    dockuttu

    Thursday, January 5, 2012 11:06 PM
  • I just uninstalled stablebit using their instructions from their wiki: http://wiki.covecube.com/StableBit_DrivePool_Clean_Re-install 

    obviously didn't reinstall.

    no go. still got the "unexpected error"

    also tried their server solutions troubleshooter.

    (http://wiki.covecube.com/StableBit_DrivePool#Windows_Server_Solutions_Troubleshooter)

    still no dice.

     

    Looks like a full re-install is in store for me. I can't get the Connector to connect and can't get my streaming media settings working (connection to streaming server settings timing out). Guess I know what I'm doing this weekend. I wanted to do a clean install of one of my W7 machines anyway. I'll kill two birds.

     

     

     

     

    Friday, January 6, 2012 6:42 AM
  • Finally got it working.

    First Step: Move folders from Drive Pool Shared to local drive. In other words, remove all the shared folders from drivepool back to the original state.

    Second Step:Grant Read/Write permission to all the shared folders to the Guest account (I dont know if its required but it worked)

    Third Step: Remove Drive Pool AddIn

    Fourth Step: Remove the Client computer with issues as it should have been added under Client computer backup list  in Dashboard

    qFifth Step: Restart Dashboard

    Sixth Step: Restart Server

    now you can go to client computer and run connector server again. It should work now. I think the issue is with the Recorded TV folder not accessible.

    dockuttu

    • Proposed as answer by dockuttu1 Saturday, January 7, 2012 4:05 PM
    Saturday, January 7, 2012 4:05 PM