none
SyncToy needs a login again to access previously accessible network source RRS feed

  • Question

  • I used to use SyncToy (2.1) on my Vista x64 Desktop to sync with my Vista x32 laptop. Since I use different passwords on the machines I had to access the laptop in windows first and type in name/password. Then i could use SyncToy to sync them.

    Recently I bought Win7 Pro x64 for my desktop, and since that time I cannot use SyncToy like that anymore. Even if I access the laptop via Windows (and type in name/pw) like before, SyncToy still needs me to log in again, but the problem is that I cannot do that in an already existing folder pair: I have to recreate the pair everytime I want to use SyncToy, which makes the program pretty useless regarding deleted files.

    Does anyone have a solution for this?

    Thursday, March 25, 2010 10:04 AM

Answers

  • After making the passwords the same, plus making the network drive point to the Documents folder itself as root (so when accessing the network drive, the contents of the documents folder was seen directly) it still did not work.

    But you wont believe this: I kept starting SyncToy as administrator because I did not want that to cause any problems. The last thing I did was to start it normally again, and.... it worked. Really strange. I wont change anything now anymore, because after so much trouble it finally functions.

    Thanks for the help!

    • Marked as answer by TheRealBugi Monday, April 19, 2010 2:12 PM
    Monday, April 19, 2010 2:12 PM

All replies

  • You can have a try by setting a network drive mapping.

     

    Thanks,

    Ping


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, March 26, 2010 4:10 AM
  • Thank you Ping Lu for the suggestion. I tried it, but this doesn't work either. I can map it and access it in Windows, but as soon as I try to access the network drive via SyncToy, it refuses to connect and tells me that the network path was not found (it also has a red cross through it).

    Edit: I found that the non-accessibility was due to PeerBlock running. I closed it, but SyncToy can still not access the network drive: "login failure, unknown user name or bad password" and "the specified network name is no longer available"

    Monday, March 29, 2010 8:08 AM
  • Hi,

    Have you tried the "net use" command?

    Thanks


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, March 29, 2010 8:25 AM
  • Did you select the option remeber the password for this user?

    And when you create the network mapping, did you select the reconnect at logon?

     

    Thanks,

    Ping


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 8, 2010 9:12 AM
  • It seems the problem has been solved by using the net use command: the windows wizard did not let me specify logon details, while with the cmd, I seem to be able to. If it hasn't worked, I'll be back on this :) Thanks in advance, anyway :)

    Update: This does not work, either. I restarted everything now, and (1) had to type the password when accessing it in Windows, even though I explicitly told it to save those credentials and (2) SyncToy tells me it "cannot locate the folder". I do not have time to further test using this feature at this moment due to external time pressure, but later on I will test (a) explicitly setting the logondomain to the laptop (it has a different computer name), (b) recreate thesame share for thesame drive letter and then try to use SyncToy on that existing folder pair (if that works I will have to make some batch script to reconnect it every time I start up ST) and (c) using thesame passwords on both machines. Option (d) then is abandoning ST I guess: bugs like that are just too hard to accept.

    Edit2: Something else I've noticed is that the name of the folder on the laptop (the right folder, as opposed to the left one on the desktop) is 'My Documents' in windows explorer, while the actual name is Documents (the one that SyncToy also stores as the path name, also the name it has in TotalCommander). Could this be problematic due to network names or so?
    • Proposed as answer by Ping Lu Monday, April 12, 2010 9:25 AM
    • Unproposed as answer by TheRealBugi Tuesday, April 13, 2010 7:09 PM
    Sunday, April 11, 2010 6:10 PM
  • After making the passwords the same, plus making the network drive point to the Documents folder itself as root (so when accessing the network drive, the contents of the documents folder was seen directly) it still did not work.

    But you wont believe this: I kept starting SyncToy as administrator because I did not want that to cause any problems. The last thing I did was to start it normally again, and.... it worked. Really strange. I wont change anything now anymore, because after so much trouble it finally functions.

    Thanks for the help!

    • Marked as answer by TheRealBugi Monday, April 19, 2010 2:12 PM
    Monday, April 19, 2010 2:12 PM