locked
strange occurance with WHS console RRS feed

  • Question

  • could not start the console this AM.  Tried to get to the admin screen vis remote desktop.  It fianlly connected, after a long wait.

    Tried to start the WHS console via remote desktop but it would not and seemed to try to reload something.

    Reported an error that "C" was full and could not continue.  Went to my computers and it reported "C" was indeed full.

    Went to add/remove programs, an in trying to remove a printer it reported no room on "C" to produce a temp file.

    Go to explorer and simply deleted  the printer install file.  Restart WHS console and it started normally.

    the drive health is normal and shows about 25% free space out of 892 gig. all the accounts show healthy and all readings are as they were yesterday when it behaved normally.

    now, my computer for the server indicates a free space of 12 meg out of 10 gig.

    What is going on? anyone else experience this?
    Tuesday, April 3, 2007 4:27 PM

Answers

All replies

  • I found this thread in the forums. Take a look and see if it's related.

    There's also a bug on Connect. You should take a look at that as well.
    Tuesday, April 3, 2007 4:50 PM
    Moderator
  • The c: drive on the WHS server is running dangerously low on memory.  Slow connect times and errors (or worse) will continue until you track down what has consumed all the memory.  Just to give you some perspective, my server, operating since Feb 22, currently has 6.75GB free on c:.

     

    There are several possibilities.  Have any applications been installed that use c: on the server for data purposes?  If so, create a share folder and point your application data to \\localhost\sharedfoldername.  Logs running wild is another likely possibility. 

     

    Explore c: to track it down.  With over 6GB beign used, the source of the problem shouldn't be hard to find.

     

    Tuesday, April 3, 2007 5:04 PM
  • I tracked down the disk space hog.  It was c:\windows\temp.  This folder had about 1200 files of about 5 meg each.  I deleted all but the active folders and now have about 6 gig free.

    What causes this and can I  prevent it from happening?
    Wednesday, April 4, 2007 12:13 AM
  • Can you describe the files that you purged?  Names, contents, etc. 

     

    What do you mean by "deleted all but the active folders"?

     

    Are these or similar files still being created?

    Wednesday, April 4, 2007 1:33 AM
  • this is an example of the file name.  XFS2a1f6a02-ea9d-45e5-8d77-18ae00a7270f.tmp

    I could on tell that the contents was not a text file.  Strangely no new files have been added in the last 24 hours.

    I deleted all the files the system allowed me to.  There were four remaining that I could not delete but contain  zero bytes.
    Wednesday, April 4, 2007 1:22 PM
  • This is pure speculation on my part, but this name looks like a log for the WHS file system (XFS + a guid). 

     

    I think that you should log a bug on the Connect site.  (I searched using the "log" keyword and didn't see anything similar.)

     

    Good luck.

    Wednesday, April 4, 2007 8:39 PM
  • in the last 24 hours, the C drive filled again with the aforementioned .tmp files (1300 of them)

    I had tried to do some remote downloading but was unable to do only one file at a time, the following message was displayed when I tried to do more than one ( I assume as part of creating the zip file)

    picture name
    .CR2 : An unexpected internal failure occurred in the FileSystem component, or one of its descendants. Type: Xceed.FileSystem.DiskFile FullName: \\SERVER\photos - mission pics\2007 mar juigalpa\rgm\bats nica mar 07\picture name.CR2 (actual file system nomenclature)

    I am assuming this was due to the C drive being full.

    Anybody know what is producing these temp files and how to turn it off?  This is getting aggravating.

    Thursday, April 5, 2007 4:57 PM
  • How many hard drives do you have in your system?

    I'm wondering if these could be related to the tomestones, or bookmarks that WHS uses when it tries to move files off the primary drive to another drive with Drive extender.  It may also be trying to use the duplication feature for the shared folders and if there is only one drive it shouldn't allow it. 
    Thursday, April 5, 2007 5:06 PM
  • I doubt it involves the tombstones, as all the files function normally after I have deleted the tmp files.

    I have not tried a restore at all...yet.
    Thursday, April 5, 2007 8:42 PM
  • I still think that you've got some low-level problems with the file system in your WHS server.  Some things to consider:

    • Were there any unusual errors or problems with drivers during the WHS installation?
    • Are your mobo/disk controller drivers up to date?
    • Are you able to back up your shared folders and re-install the server?

    Although this won't fix anything, you really should post a bug for this issue.  (Definitely before you reinstall.)

    Thursday, April 5, 2007 9:30 PM