locked
Time Zone in Workflow Timeout Issue RRS feed

  • Question

  • I have seen several posts related to this issue, but I can't find any answers for how to fix this issue.

    I am using CRM 2011 Online version 5.0.9688.1055.

    I have created a Workflow with a Wait Condition: "Process Timeout Equals 5 Minutes After Task:Created On"; after the timeout, the Workflow generates an email message to a particular user. To test this, I entered a dummy Task and checked the System Jobs to verify the Process was completing as expected.

    When I check my System Jobs, the Workflow was stuck in the "Waiting" status for longer than anticipated. I opened the System Job and saw the "Postpone" value was 5 hours from when I expected it to run. I believe this is because the Time Zone for CRM 2011 Online is set to GMT; however, the users of our system are in the Eastern Time Zone.

    Is there a way to have the Workflow Time Zone setting match the user's Time Zone setting? I have verified that all users are set to the Eastern Time Zone and I can't find a way to modify which Time zone the Workflow is using.

    This is a high prioriy issue for us - we plan to use Workflows for notifications of due dates and if the Time Zones don't match, it's possible that a notification will sent on the wrong day.

    Thursday, May 26, 2011 3:44 PM

Answers

  • I have a workaround that might work for you: If your workflow is triggered on record creation and you just want to wait until 5 minutes after the record is created you can simply insert this condition:

    Process - timeout - 5 minutes (use the duration option)

     

    That works fine because in your case, it might be equivalent to "wait until 5 minutes after record is created" because the workflow executes when the workflow is created (assuming no other wait steps before). I've verified that works regardless of timezone!


    Gonzalo | gonzaloruizcrm.blogspot.com

    Friday, May 27, 2011 2:37 PM
    Moderator

All replies

  • Hi Meghan,

     

    Expressions like "5 minutes after task is created" should not be timezone dependent, because it is just a duration (timeout) that starts the moment the task is created.

    Can you please let me know these details so I can help you further:

    1. Timezone for the user who triggered the workflow (as set in the user preferences options)
    2. Is the workflow on-demand or triggers automatically (if so, on what event does it trigger)?
    3. Timezone for the owner of the workflow (as set in the user preferences options)

    Gonzalo | gonzaloruizcrm.blogspot.com

    Thursday, May 26, 2011 5:57 PM
    Moderator
  • Hi Gonzalo,

    Yes, I understand the expression is not timezone-depenedent; however, because the workflow is using a different timezone than I am, it's acting as though the "moment" the task is created is at a different time of day. For example, I create the task at 11 a.m. Eastern Standard Time and the expression should cause the workflow to kick off the next step at 11:05 a.m. EST (since the timeout is 5 minutes after the task is created). However, when I open the Workflow from System Jobs, it is showing the initial action as happening at 4:00 p.m. and kicking off the next step at 4:05 p.m. So the step itself is not timezone-dependent, but it's causing an issue for me.

    In answer to your questions:

    1. Eastern Standard Time
    2. Workflow is automatically triggered on Record Creation
    3. Eastern Standard Time

    Thursday, May 26, 2011 7:40 PM
  • Hi Meghan,

     

    That is a very nice find, unfortunately I cannot help but confirm that this is a bug on Microsoft...I suggest opening a ticket for it.


    Gonzalo | gonzaloruizcrm.blogspot.com

    Thursday, May 26, 2011 7:58 PM
    Moderator
  • Thank you. I will open a support ticket for this issue.
    Thursday, May 26, 2011 8:35 PM
  • I have a workaround that might work for you: If your workflow is triggered on record creation and you just want to wait until 5 minutes after the record is created you can simply insert this condition:

    Process - timeout - 5 minutes (use the duration option)

     

    That works fine because in your case, it might be equivalent to "wait until 5 minutes after record is created" because the workflow executes when the workflow is created (assuming no other wait steps before). I've verified that works regardless of timezone!


    Gonzalo | gonzaloruizcrm.blogspot.com

    Friday, May 27, 2011 2:37 PM
    Moderator
  • Yes, thank you! Using the "Duration" option fixed my issue.
    Friday, May 27, 2011 5:27 PM