Principal User missing prvReadSolution privilege RRS feed

  • Question

  • I am the admin of an org and a deployment manager for what its worth. I took a full backup of the org DB and performed a restore to a new DB on the same server to create a new org. Using deployment manager I then ran an import org and all was worked with no errors. However when I attempt to access the url for the new org I get an error principal user is missing prvReadSolution privileges. 

    I have not had this problem before as I've followed the above steps a number of times in the past. I also took the same backup and was able to create a new org using that backup on a completely different server also. Seems like whenever I try to create a new org now on this particular server I get this error, although I had just done so successfully a few days ago.

    any ideas?



    Tuesday, October 29, 2013 10:48 AM

All replies

  • Hi,

        The error indicates that the user you are trying does not have read access on solution entity.



         If this is the only user in the organisation and you have access to the original CRM instance, please make sure it works as expected for the given user and then try the process again.

    Hope this helps.
    Minal Dahiya
    blog : http://minaldahiya.blogspot.com.au/
    If this post answers your question, please click "Mark As Answer" on the post and "Vote as Helpful"

    Tuesday, October 29, 2013 11:12 AM
  • Thank you.  There are several users, myself included and I have system admin rights privileges . I cannot get to 'setting's etc with my login due to the error. When I import the org the log file shows no errors and shows my account being mapped as administrator successfully.


    Tuesday, October 29, 2013 11:59 AM
  • if this is the only server that has the issue and new orgs and imported orgs have the issue i would take a look at the update rollup levels and possibly do a repair on CRM.

    Also you said it worked previously, what has been changed since then?

    Wednesday, October 30, 2013 12:52 AM