locked
Simultaneously Ring Grayed Out - But GP Enabled? RRS feed

  • Question

  • For some reason, in our Communicators and Polycom phones the option to configure a number for simultaneous ringing is grayed out. I have turned that feature on in Group Policy though (By setting "Disable simultaneous ringing" to Disabled) and I've made sure the Usage Policy is set to allow simultaneous ring. Any ideas on why we still can't set this setting?

    Saturday, August 15, 2009 12:21 AM

All replies

  • Are all of the other Enterprise Voice features functioning? Specifically do you see 'Forward calls to' as an option as well as Call'-forwarding Settings'?
    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Monday, August 17, 2009 11:09 AM
  • I have the following options:

    Ring me
    Forward to my voicemail, a number, or a contact

    Thanks!
    Monday, August 17, 2009 4:08 PM
  • To better answer - yes, I see those questions, and when choosing "Call Forwarding Settings" I have the options I listed earlier.
    Monday, August 17, 2009 11:55 PM
  • What is your current Enterprise Voice scenaio? From the Mediation server where/how do calls route?
    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Tuesday, August 18, 2009 8:38 AM
  • From the Mediation server, the calls go to our Asterisk PBX.  This worked fine with OCS 2007, and nothing has changed there - the PBX is exactly the same. The only change is the OCS 2007 to 2007 R2 upgrade, which was performed using the uninstall/reinstall method.
    Saturday, August 22, 2009 12:05 AM
  • I also have exactly the same problem, and it's only come about since upgrading the OCS R2. If you use the OCS R1 client the simultaneous ring option is available. Don't suppose you've come across the answer yet have you?
    I've recreated all my policies in OCS but that hasn't made any difference.
    Friday, September 4, 2009 3:03 PM
  • Have you tried a new user? When the upgrade was performed were the users de-provisioned and re-provisoned using ADUC or LCSCMD?
    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Friday, September 4, 2009 3:07 PM
  • I don't believe they were de-provisioned then re-provisioned.  I performed the upgrade as per the migration guide from Microsoft. 
    Friday, September 4, 2009 5:12 PM
  • Understood - so the new OCS R2 server was stood up in conjunction with the exisiting OCS server and the users were moved?
    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Friday, September 4, 2009 5:59 PM
  • Brian, i think we're heading in the right direction here but something is still a miss. I too followed the MS migration guide but there was no mention of de-provisioning/re-provisioning users. So I created a new user and enable it in OCS and simultaneous ring is now enabled for that user (permanently).

    So I used Dbimpexp.exe to export the contact etc on my OCS profile and deprovisioned/reprovisioned it and that too had simultaneous ring capabilities afterwards.

    However i've come back to it a few hours later and it's greyed out again. Do you know if there's something embedded in OCS that is replicating and causing this issue, maybe something i should be searching for in WMI?
    Friday, September 4, 2009 7:16 PM
  • Do you have a user you could simply deprovision, remove from the OCS RTC DB permanently (removing the user from the GUI) and then re-provisioning (i.e. not running a dbimpexp which I wouldn't expect to tbe the problem but...)?


    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Friday, September 4, 2009 7:22 PM
  • I do not have a user I could try this on - Vince, do you?

    Also, interesting note - I CAN configure the Simultaneously Ring option from Communicator Mobile.   The setting seems to "stick" and in the Communicator desktop client it shows it's turned on, though greyed out.
    Friday, September 4, 2009 9:15 PM
  • Only for validation, try to install a fresh machine and don't join on domain. To make sure which there are none policies applied.
    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist | http://brunoestrozi.spaces.live.com
    • Proposed as answer by VinceW Saturday, September 5, 2009 10:54 PM
    Saturday, September 5, 2009 6:15 PM
  • Brian, thanks for your suggestions on this issue it seems to be resolved now. On Friday i removed myself from the OCS database and then enabled it again and as i mentioned above the simultaneous ring option worked for a little while and then got greyed out again. At the time i immediately ran the dbimpexp to replace my contacts which i thought was the cause of the problem reappearing.

    However, i've run through the process again with my own profile and the simultaneous ring is still available after 24 hours even after importing contacts again??? Not sure what happened the first time, but i've followed the above process for all our users now so hopefully on Monday i can confirm if everyone has this feature enabled. Cheers. Vince
    • Proposed as answer by VinceW Saturday, September 5, 2009 11:00 PM
    • Unproposed as answer by ngarrett Monday, September 7, 2009 7:14 PM
    Saturday, September 5, 2009 10:59 PM
  • I attempted Bruno's suggestion, and found that non-domain systems could choose the Simultaneous Ring option.  I messed with GP some more and modified the setting for "Telephony Mode" from "3 - Dual Mode" to "1 - UC Enabled".  A quick gpupdate later and Simultaneously Ring was enabled...
    • Marked as answer by ngarrett Monday, September 7, 2009 7:14 PM
    • Unmarked as answer by ngarrett Monday, September 7, 2009 7:14 PM
    Sunday, September 6, 2009 8:14 PM
  • Well, it looks like a spoke too soon, after Simultaneous Ring being available all weekend, I come in this morning to find it's greyed out again. I have to admit i dismissed Bruno's comment as i have non domain machines that have exactly the same problem, even if they're completely outside the domain and network connecting through the edge server.

    Can you tell me where you configured the "Telephony Mode" in the GP, i assumed that since I've not specifically changed anything and the R1 client works fine that the GP's must be fine.
    Monday, September 7, 2009 8:55 AM
  • You can find the Communicator GP documentation for R2 here: http://www.microsoft.com/downloads/details.aspx?FamilyID=5d6f4b90-6980-430b-9f97-ffadbc07b7a9&displaylang=en.  Here's the summary of my GP settings, in case they have relevance:
    Allow hyperlinks in instant messages: Enabled
    Allow storage of user passwords: Enabled
    Configure SIP compression mode: Enabled - Always enabled
    Disable email comparison check for Outlook PIM integration: Enabled
    Disable simultaneous ringing: Disabled
    Enable the state Appear Offline: Enabled
    Enable web browser in conversation window: Enabled
    Launch Microsoft Office Communicator Tour: Disabled
    Specify transport and server: Enabled (the settings are set to my internal and external DNS names, with TLS chosen for the transport)
    Tab URL: Disabled
    Telephone Mode: Enabled, Set at 1 = UC Enabled
    Turn on event logging for communicator: Enabled
    I have these settings configured in both the user and computer GP locations.  I could probably remove them from one or the other, since this is linked to the root of my domain.

    Let me know if you come across any findings here. Your experience doesn't give me much hope that my issue is permanently solved.
    Monday, September 7, 2009 7:14 PM
  • Thanks for the GP info, as a quick test i just created the "TelephonyMode=1" DWord under HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Communicator and this has fixed the problem on my client. But in my opinion this is a bit of a "bodge":

    By the letter of the law at http://technet.microsoft.com/en-us/library/bb963959.aspx if these registry keys don't in Local_Machine or Current_User then it should use In-Band settings. But if the In-Band settings are correct then I don't see why this option is disabled. And it still doesn't explain why the R1 Communicator works without TelephonyMode change and also why a BRAND NEW OCS user works and existing ones don't...

    Don't get me wrong i'm happy that this is a fix, although i can't help thinking there's something else in OCS that needs tweaking
    Tuesday, September 8, 2009 1:43 PM
  • I am actually leaning the other direction. Perhaps we've uncovered a flaw or "undocumented feature" in Communicator R2 that's causing this behavior.  The technet article linked above is for Communicator R1...

    I don't know where you'd change this setting in OCS, unless it's some WMI or CLI setting you perform apart from the management GUI?
    Tuesday, September 8, 2009 5:49 PM