locked
Warning about USB drives with Windows Home Server RRS feed

  • General discussion

  • Wanted to give new WHS users a heads up on some issues I ran into and the solutions.
    First off, I have never been a USB fan, even with the new USB 2.0 as I have always found firewire faster even though the "theoretical" numbers were higher.
    So I had a computer, Intel motherboard/P4 processor/1 GB RAM and had that setup with 3 IDE hard drives in it.  I figured I would make things easier on myself and add the additional storage pool drives as USB drives so in case of failure I would have an easier time.
    I added a USB 2.0 PCI card with 4 external ports along with the 4 USB 2.0 ports on the motherboard.
    I added 5 more hard drives through USB external enclosures.
    Worked.....for a few days.
    Then all of  a sudden I would get critical errors because a drive would be missing.  I would unplug it and replug it in to no avail. 
    This seemed to happen during the evenings when storage balancing and backups would be performed.
    This kept happening.  I would have to remove the drive, shut down.  Restart with the drive not hooked up, get into the console, plug the drive into USB and then add it again.
    Well, this got to the point that it was happening every day.  I even had a fan setup to keep the drives cool thinking that was the issue.
    So one day, out of frustration, I took the guts of the home server computer and built it into a server case with lots of room for internal hard drives and cooling fans.  I then would remove a USB drive, open up the enclosure, take out the SATA drive and put it in the server case.  I ended up adding a 4 internal/2 external SATA card to give me more ports as the Intel board only had 2.
    Took at while as removing a drive can take some time, but eventually I got all 5 SATA hard drives added.
    Problem completely gone.  Don't have this issue anymore.  USB bus must have been overwhelmed.
    Now I had one USB external drive left, a Lacie 750GB drive that I wanted to use as a server backup for all the data.
    I plugged it in to the USB, didn't add it to the storage pool but as a backup drive, and started to backup about 1 TB of data which would be backed up in about 370GB.
    So I start the server backup.  At about 17% I start getting errors.  Figure out the errors are related to the USB drive freezing up.  Try a couple times, eventually the backup works.
    Well now I'm frustrated.  I end up breaking the hard drive out of the Lacie enclosure as it was sealed, take the SATA drive out, put it in a Esata enclosure, and have not had one problem since.
    USB just can't handle vast amounts of data obviously. 
    My suggestion, don't use it and avoid the frustration that I had.

    Monday, February 2, 2009 7:07 PM