locked
sora sdk 1.5 HVT/ can't send a test signal RRS feed

  • Question

  • Hello-. I got some questions.

    we have a problem with sending a  signal in HVT. as a manual says,  we installed sora sdk 1.5 and HWTest driver on two sora boxes. ran HVT, set everything to what manual said but sender didn't work.

    following is a log message.

     

    SoraUInitUserExtension called

    success

    SoraURadioStart called

    success

    SoraURadioSetFreqOffset called. freqOffset set to 0

    success

    SoraURadioSetTxGain called. txgain set to 0xf00

    success

    SoraURadioSetRxGain called. rxgain set to 0x2000

    success

    SoraURadioSetRxPA called. rxpa set to 0x1000

    success

    SoraURadioSetCentralFreq called. centralFreq set to 2422000

    success

    SoraURadioMapTxSampleBuf called

    success

    SoraURadioTransfer called. SampleSize = 1048576

    Failed. ret = 80050003

    SoraURadioUnmapTxSampleBuf called

    success

    SoraUCleanUserExtension called

    here's a spec. of our system.
    Intel Core i7 950 @3.07 
    Gigabyte X58A-UD3R
    DDR3 4gb RAM x 1
    Windows XP SP3 (english)
    there was a singal shape on the overview window of receiver sora box. so we think receiving is ok.
    actually we had a problem with sending/receiving test between since sdk 1.1. though we installed sdk 1.5, we guess there is some same problem. 
    and is it right that we can't change central frequency in hvt? there was only 2422Mhz option. (the way of changing sampling rate value (say, 40MHz->44Mhz) is a little bit strange too. there wasn't any options when we clicked down arrow button, nothihng was turned up. we could change the value from 40 to 44 by pushing keyboard arrow button, though.) we guess it may be due to collision between sora machine and our wifi AP so that we wanna set channel, like #10(2457mhz) to avoid it.

    Wednesday, September 7, 2011 12:53 PM

Answers

  • I'm not sure Sora works on your Gigabyte X58A-UD3R motherboard. Suggest you try "dut transfer" and check whether the transfer process will success. There could be comptibility issue which cause the transfer process fail.

    -Jiansong

    • Marked as answer by Kun Tan Wednesday, September 21, 2011 1:34 PM
    Thursday, September 8, 2011 7:33 AM
  • thanks for all replies.

     

    It was due to mainboard's compatibility. After changing mother board, HVT works well.

    (but still have no idea why i can't change HVT configurations)

     

    -dk

     

    • Marked as answer by d_k_fox Thursday, September 22, 2011 6:30 AM
    Friday, September 16, 2011 6:06 AM

All replies

  • I'm not sure Sora works on your Gigabyte X58A-UD3R motherboard. Suggest you try "dut transfer" and check whether the transfer process will success. There could be comptibility issue which cause the transfer process fail.

    -Jiansong

    • Marked as answer by Kun Tan Wednesday, September 21, 2011 1:34 PM
    Thursday, September 8, 2011 7:33 AM
  • For the UI issue (wrong size of combo box), it's caused by different version of common controls library.
    You can fix this by specify the visual style in a manifest file.

    Please create a file "HwVeri.exe.manifest" under %SORA_ROOT%\bin, then copy below content into this file:

    <?xml version='1.0' encoding='UTF-8' standalone='yes'?>
    <assembly xmlns='urn:schemas-microsoft-com:asm.v1' manifestVersion='1.0'>
      <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
        <security>
          <requestedPrivileges>
            <requestedExecutionLevel level='asInvoker' uiAccess='false' />
          </requestedPrivileges>
        </security>
      </trustInfo>
      <dependency>
        <dependentAssembly>
          <assemblyIdentity type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' processorArchitecture='*' publicKeyToken='6595b64144ccf1df' language='*' />
        </dependentAssembly>
      </dependency>
    </assembly>
    
    


    Thursday, September 8, 2011 9:48 AM
  • thanks for all replies.

     

    It was due to mainboard's compatibility. After changing mother board, HVT works well.

    (but still have no idea why i can't change HVT configurations)

     

    -dk

     

    • Marked as answer by d_k_fox Thursday, September 22, 2011 6:30 AM
    Friday, September 16, 2011 6:06 AM
  • Hi dk,

    Can you please tell which motherboard+processor worked for you with SORA ?

     

    Thanks,

    Bk

    Wednesday, September 21, 2011 3:19 PM
  •  

    asus p6x58d-e with i7 930 cpu.

     

    good luck.

     

    -dk

     

     


    • Edited by d_k_fox Thursday, September 22, 2011 6:27 AM
    Thursday, September 22, 2011 6:26 AM
  • Thanks!

    -bk

    Thursday, September 22, 2011 6:34 AM