locked
Error in Outlook upon installing CRM 4.0 - New install, users never had CRM 3.0 RRS feed

  • Question

  • After installing CRM 4.0 on about 42 machines, each user received the  "An error occurred loading Microsoft Dynamics CRM functionality.  Try restarting Microsoft Outlook.  Contact your system administrator if errors persist."

     

    Usually, closing Outlook and restarting would work, but not this time.  We found that the only way we could get users to be able to open Outlook and use CRM was to add the System Administrator role to their CRM user profile, have them open Outlook and then remove the System Admin role.

     

    I am wondering, as this is the first time we've done a rollout of CRM for a group that did not previously have CRM 3.0, if anyone else has seen this.  I thought at first that it might have something to do with creating multiple users at a time, but that proved to be false, as I created one user individually and had to do the same 'fix' as I did with everyone else.

     

    It also seems that the Roles work a little differently than they did in 3.0.  We created the roles off of what we had in 3.0 and identically to those that have been upgraded from 3.0 to 4.0 and we had to tweak the new ones for 4.0 in order for all of our customizations to work.  All deployments have the same customizations, so this doesn't make sense.

     

    Help if you can.

    Thanks.

    Wednesday, December 10, 2008 9:25 PM

All replies

  • Hello,

    We have run into this issue as well.  Is the only solution to give the user the Sys Admin role?  Or has Microsoft offered a better one?
    thank you.
    Friday, February 20, 2009 3:08 PM